Nucleus Web Administration Interface "This site can’t be reached" error

My setup was working yesterday with Google Fiber 1 Gig Router. Upgraded home connection to Google Fiber 2 Gig Router today and want to get the most from Roon. Unfortunately, I can’t get reconnected.


  1. Settings - Setup - Find Roon OS
  2. Select Nucleus+ from lsit of Roon OS Devices
  3. Browser launches - page lands on:

This site can’t be reached is unreachable.

Please help!

  • Details on your Core machine (OS, Hardware specs, Roon build) - Nuclues+
  • Details on your Remote(s) (OS, Hardware specs, Roon build) - MacBook Pro
  • Networking details (especially what hardware you’re using, how everything is connected, and anything notable about how it’s all configured) - Nucleus+ connected to Google Fiber 2 Gig Router (Silver Port)
  • Audio devices in use - N/A
  • Library details (where your music is stored, whether you’re using a streaming service, how many tracks are in your library) - 8TB SSD mounted into Nucleus+

@JimmyS, welcome to the Community. Can you go into your Google Home app and verify the IP address of your Nucleus+? When you upgraded to the new 2 Gbps service Google may have reset your internal IP addresses.

Alternately, can you confirm the IP address of your Nucleus+ by typing http://nucleusplus or http://nucleusplus.local? Have you rebooted all of your devices on your network after the 2 Gbps upgrade?

Are your other devices (non-Roon) working correctly on your upgraded network?

I also re-categorized this to the Nucleus Support category.

Thank you for re-categorizing.

The IP address of the new router is so it doesn’t seem like it has changed. Not seeing Nucleus+ in Google Home app. Trying to add it doesn’t bring anything up.

Neither of those nucleusplus links do anything (similar site can’t be reached message).

All other devices (non-Roon) reconnected. We did need to create a new network. Once other devices were switched to the new network, they worked.

Since your Nucleus+ is not visible on the new network, can you confirm it is working properly? Have you rebooted it?

I have turn the Nucleus+ on and off multiple times trying different things so I think that would work.

Is there a specific way I should confirm Nucleus+ is working properly? I am trying to pinpoint what is going wrong it seems to be either a connection issue between the new router and the Nucleus+ or something with IP address matching. I can’t figure out anything more specific.

One method is to connect its HDMI output to a monitor while it is on the network and see what appears on the monitor screen. If it cannot be pinged on the network or accessed via a web browser, then this is the next approach.

It is solved! This was likely my misunderstanding of the Google installer early today. He connected the ethernet cable to a port that was not compatible with Roon but told be it would be (he may be right but it will take a lot more work to fugure it out). Once I switched it to a standard port, it worked almsot instantly. Really appreciate your help.

Do you have a link to the best way to mark something solved/close out?

1 Like

Glad you are back up and running @JimmyS, one of the mods already marked this as Solved. Enjoy the music!

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.