Nucleus+ will not connect after brief power outage (again!)

Roon Core Machine

Roon Nucleus+ (rev. B)

Networking Gear & Setup Details

Verizon Fios router
Network switch

Connected Audio Devices

Nucleus+ connected via LAN
Endpoints connected via wi-fi (Microsoft Surface Studio, Surface Pro, 2 cellular phones)

Number of Tracks in Library


Description of Issue

Once again, a brief power outage in my house has bricked my Nucleus+. I am having the same issue as the prior two times this happened - I am unable to connect to the Core with any of my endpoints, and the Nucleus+ is not visible on my network.

I tried the same things you advised last time:

  • Rebooted my network repeatedly
  • Rebooted the Nucleus+ repeatedly
    *Rebooted the switch
  • Unplugged everything overnight and re-connected everything in the morning.
  • Turned off my VPN
  • Connected the Nucleus+ to a monitor via HDMI, and used a USB keyboard to enter “resetnetwork”. I repeated this step after the Nucleus+ failed to connect, and after again rebooting the router and home network.
  • Connected the Nucleus+ directly to my router

None of these steps worked. When connected to a LAN cable, the lights on the back of the Nucleus+ are green, and I am able to use the same LAN cable to connect other devices to my network. The Nucleus+ powers up when restarted, with the power button glowing white.

The Nucleus+ has been working flawlessly for the past 9 months. I have already shipped it back to you once, back in November 2021, right at the end of the warranty period. After I received the unit back from you, I communicated with the technician who worked on it, and they told me that there was a BIOS issue that had to be rectified. It has worked flawlessly until the very brief power outage in my neighborhood yesterday.

None of my other devices were affected by this outage, including my McIntosh integrated amp, Sony monitor, Oppo blu-ray player, several other network streaming devices, my home appliances, etc. All of my wi-fi devices have been able to connect to my home network without incident. Only the Roon Nucleus+ was affected.

While I assume I will likely have to purchase a UPS unit to ensure that the Nucleus+ does not lose power, it seems clear that something is wrong with my Nucleus, and has been wrong since it was new. I really shouldn’t have to spend a weekend hair-shirting my home network, only to still have a bricked Nucleus+.

The two prior identical incidents are linked in these threads:

@support - can you help, please?

Chris Gibson

Hi Chris,

Not support, just a fellow user.

It is unclear to me whether you actually had boot information on screen. If so, did it indicate that it received an IP address? And, If it did display an IP address, how is that address compared to the rest of the network. It is possible that in the power outtage caused a network reset that changed your network addressing leaving the Nucleus on a different subnet.


Thanks, Daniel. It did not indicate an IP address. See attached photo of the monitor display.

I still cannot connect to the Core, nor will my Nucleus+ be recognized by my router.

@support - can you help, please? Thanks.

Try a different cable. Unplug and replug your current one.
Is there a link light showing electrical pathing?

Yes, I switched cables, to no effect.

I dont know what a link light is, but the LAN port is flashing green, so yes, it does appear to be properly connected.

Thanks for the suggestions!

1 Like

Hey @Chris_Gibson,

Ben with the support team here, thanks for providing all the information above, and I’m sorry to hear you’ve hit more issues with your Nucleus. We definitely suggest grabbing a UPS unit to avoid any future issues.

For a next step, can you please try to connect using a USB to Ethernet adapter on your Nucleus? Let me know if you’re able to make any progress this way :+1:

1 Like

I would try a different port on the switch as the next step.


@benjamin - thanks for your reply. I don’t have an adapter like that, but I can probably get one. Are you suggesting that I connect an ethernet cable from my router to a USB adapter, and then plug the USB into the Nucleus+?

@Rugby - I am connected directly into the router at this point, but thank you for the suggestion.

My FIOS router has switch ports in the back (4 of them in yellow). If yours does at well, I am suggesting using a different port as ports can also “go bad”

1 Like

USB ethenet adaptors are as cheap as chips from JeffWeb, it just plugs into the USB port on the Nuc, using one of these will let you know if the Onboard Ethernet Adaptor is frazzled or if you have a Static IP set on the Nuc.


@benjamin - I secured an adapter, and no, the Nucleus+ would not connect via USB.

@David_Brown - thank you for the photograph and explanation. Much appreciated.

1 Like

Hey @Chris_Gibson,

Thanks for giving that a go! The good news here is that your Nucleus is still booting. I suspect that something has gone wrong with your Nucleus operating system. Let’s try this - can you please flash ROCK onto a USB drive and install ROCK on top of the Nucleus OS? E.g. everything from step #3 onward from this guide (no need to flash BIOS):

Then once ROCK is successfully running on the Nucleus, we can remotely flash it back to Nucleus OS.

Let me know if you have any questions at all :+1:


@benjamin - thanks. I am unable to complete these steps, as the Nucleus+ is now refusing to output anything to a monitor via HDMI.

I believe it is time for an RMA and a thorough diagnostic review of this machine. Something is wrong here. Please advise. Thanks.

Won’t doing Reinstall from the Web UI accomplished the same thing? I am following this thread because a friend who has a Nucleus Plus also has similar problems lately and I have been trying to figure out if it is a hardware issue, a software issue or a network related issue.

He told me that this first happened right after he unplugged the power cord from this Nucleus Plus while it was still on to do a Power Cords comparison. So I suspected some kind of software corruption. So I did a Reinstall from the Web UI and it kind of worked for a while but then he reported to me that it does it again. I want to flash ROCK to his Nucleus Plus but am afraid that his Nucleus Plus will always be a ROCK and not Nucleus Plus anymore.

1 Like

No, once the Nucleus is running under ROCK, support can update it to the proper Nucleus software.

I guess I’m glad I’m not the only one, although I’m sorry to hear that your friend has been having similar issues. It’s been incredibly frustrating, especially since I bought the Nucleus+ in order to avoid having to tinker with it. None of my other computers have any issues after the power outage - 2 PCs, a NAS, and a laptop, all running whilst the power went out. Only the Nucleus was affected, and this is the third time.

Is the change from ROCK to Nucleus be done automatically once the unit is back online or would I have to raise a support request to have it done?

No need to raise a new Support Request. Once you’ve installed ROCK on your Nucleus, send a Private Message to @benjamin referencing this Support thread, and he’ll take it from there.


Great. Thank you.

Hey @Chris_Gibson,

Thanks for letting me know, I will follow up with next steps for the RMA via private message :+1: