Nucleus+ with Benchmark DAC 2

I just purchased a Nucleus+. I have it connected to a Benchmark Media DAC 2. Nucleus recognizes the DAC, but I have no playback. Nucleus rapidly goes through a list of selections to be played and then returns a message saying “Nothing Playing.” I am not sure how to begin addressing this issue.

Sounds like a library issue. Where are your music files located? When this happens to me, it’s because the directory share didn’t connect.

You may need to adjust your Benchmark to accept USB 2.0. Hold down the “USB” button on the remote until the 4x light is steady. There are instructions in the Benchmark manual if needed. Good luck.

Tagging @support

I have a DAC 3, I had to do what @Stephen_Young1 says, solved the problem.

Hi @Rowan_Crews,

Have you tried the steps suggested by Stephen above?

If that yields no change, can you verify if other endpoints are able to play without issue?

I did as Stephen suggested. Benchmark rep advised the same. Setting USB2 solved problem. Thanks to all for helping me.

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.