Nucleus with Roon 1.7 does not play with T+A MP8

Core Machine (Operating system/System info/Roon build number)

Nucleus with OS 1.0 build(183) Server software 1.7 (build 500) and Labs software 1.0 (build 12)

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Ethernet with AQvox switch connecting Nucleus to T+A MP8 and Melco N1

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

T+A MP8 and T+A Dac8 all updated to current T+A firmware

Description Of Issue

After update to Roon1.7 Nucleus seems not to recognize MP8 as an audio device. Roon1.7 does recognize my Dac8 and playing audio (either from the Melco N1 or from the in Nucleus installed SSD drive) works fine.
Having rebooted all devices including the network switch results in erratic Roon behavior. Sometimes it does recognize the MP8 as an audio device but at other times it doesn’t. But even if Roon recognizes the MP8 it still won’t allow any playback.The track in the playback screen is a different one then the track displayed in the Roon selection screen AND the Roon playback controls are greyed out and do not work.

This has taken a significant amount of time allready and I would appreciate some guidelines as to how to solve this mistery.

Both MP8 and DAC8 worked flawlessly under the previous Roon release, and no changes have een made to the network topology since the Roon upgrade to 1.7.

Any help is appreciated

Please see:

Thanks for the link. Applying the Beta update to my MP8 solved my problem.
Thanks to T+A for their excellent (weekend…) service.

There is a new stable firmware release now available. No need to install the beta firmware any longer.
For details please see this thread:


This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.