NucleusPlus not working

Roon Core Machine

I have had very few problems over a two-year plus stretch since I first purchased the NucleusPlus directly from Roon. Three days ago, I turned on my audio system (note: the NucleusPlus core is always left on), and it came back saying it cannot find the Roon Core.

I have been troubleshooting for the last three days in order to avoid wasting anyone’s time here at community support, but I am at wits end. I have tried everything I can think of, but let me first describe the issue and setup.

I am trying to stay calm about this, but I have spent a lot of time looking through all the problem reports from others and it doesn’t seem like this is a simple software issue (I’m a novice, so I may very well be wrong). It feels like to me like it may be firmware or hardware related. Which is a huge bummer, since I think I’m out of warranty and I am retired. This was going to be my forever system, and I was extremely happy with roon up to now.

I am reaching out to you folks and hoping that maybe you can help. Anything is greatly appreciated. P.S….if it does turn out to be a hardware issue, is there a place I can send the unit for repair?


Networking Gear & Setup Details

Describe Your Setup

• I have a Roon NucleusPlus media server connected to my Archer A7 router
• It streams to an UltraRendu streamer that feeds an ADI RME-2 DAC
• That feeds a Marantz 5010 AVR, which acts as a pre-amp to
• A Carver M-500t power amp

The Roon Nucleus Plus:

• Listed on bottom label as Nucleus+ (rev.B)
• S/N 54B2038D0E59
• Should be rev.2 software
• I installed a 2TB Samsung SSD for my content
• Content is about 2000 albums (30K tracks) on the SSD
• Utilize Tidal (Masters) for streaming with personal library


• Samsung Galaxy Tab 10A tablet
• Motorola G7 phone
• Lenovo IdeaPad Flex

Connected Audio Devices

Number of Tracks in Library

Description of Issue

Describe the Issue

• The NucleusPlus is not recognized by my network. The power light switch is on, the ethernet cable shows yellow and flashing green, but it no longer appears on my network. I used to see it from other ethernet wired PCs, the router software, (and of course, the roon remote phones and tablets). This is a permanent situation right now.
• I even tried to access the unit via HDMI, but there is only a blank screen
• I have swapped out cables, router connections, switch connections, turned everything on and off a hundred times, rebooted everything a hundred times, etc. Nothing works. Still no evidence of a NucleusPlus core machine on the network.

If you haven’t plug up the Nucleus to a monitor and see what it displays on the screen.

Thanks for the response.
I plugged the Nucleus into a monitor, and it just showed a blank screen.

@support. The Nucleus seems unresponsive.

1 Like

Yes, that is exactly the case. Not sure what I should do.

@Patster11, when did you purchase your Nucleus Plus, and did you purchase it from a dealer or directly from Roon?

Just hang tight. I pinged support to alert them.

Thanks folks for responding. I purchased the Nucleus Plus unit direct from Roon around June 24th, 2020.

I take that back. I didn’t remember correctly. I actually ordered the unit through Amazon on June 7th, 2020 for a total of $2666.62.

Sorry, this the correct purchase information

Thanks Patster, Roon support should be in contact with you soon.

Thanks very much…

Hi @Patster11,

Thank you for writing a verbose description including your setup details.

I wish I had a better outlook for you but it looks like the board on your Nucleus has gone bad. I will send you a private message with a template for you to complete if you’d like to get the unit repaired.


This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.