Occasional dropouts with Microrendu endpoint

Nothing is for sure. Decent chance it will work. Doesn’t cost a lot to try.

Installed Netgear GS 205 switch and it completely cured the issue. I’m listening microrendu for more than week and there are no audible dropouts. Log files are also free from NAK messages. The only thing that I noticed once was a short pause between two gapless tracks. It was not logged as dropout and I was not able to reproduce it more times. Question to @brian: I already seen old reports about rare pauses between gapless tracks on the board, but it seems to be fixed in Roon for a while. Do you have any pending issue tickets regarding gapless playback? Is it possible to catch such issue in Roon logs?

I haven’t heard a report like that for a long time. There are no issues like that open.

@support, have you guys heard anything?

The last mention of such issue was Aug 31 Gapless playback problem

@brian and @vladimirkl ---- I have not heard anything as of recent. I am familiar with the thread that is being referenced and we tested media in house if memory servers correctly and reported no issues back to the user.

-Eric

@brian, @support - sorry, but I’m sure that Roon has a problem with gapless - at least for me. Got another random pause between gapless tracks on another album. The whole album is just one long song splitted to 7 tracks. Total length is about 40 minutes of 44/16 audio. I’ve got a pause before last track but all previous track transitions were correct. Was not able to reproduce issue again. Please let me know how you can solve my issue and what I should provide to help diagnose it. Unfortunately issue is not specific for single album and no easy way to reproduce it. I can send you tracks but not sure that you will get same issue again. Is there some debug mode that may help to catch this issue in log? I can switch it on and play on mute several different albums for a long time.

Yeah, I believe you’re having a problem–was just answering your question directly by saying we aren’t currently tracking this issue.

The best thing to move forward would be a support package captured immediately after the issue occurs. @support can provide some resources for how to do that.

1 Like

Hi @vladimirkl ----- Thank you for the feedback. I will be following up with you momentarily via PM to grab a set of logs from you so our developers can have a closer look into this issue.

-Eric

Having the same problem with MicroRendu…dropout every 15 seconds or so…mr is run off cable connection to Airport time capsule with MacMini core also connected to that…will try netgear switch next week when I can get hold of one. Problem seeks worse than when I installed mR a few days ago, and also seems to be getting worse daily so it should be called frequent rather than occasional dropouts now

Hi @diw ------ Thank you for the report, my apologies for the troubles here. To help aide in my evaluation of this issue you are experiencing may I kindly ask you to please provide the following:

  1. An expanded description of your current setup as seen here. The more detailed you can be, the better :sunglasses:

  2. An expanded description of your network configuration / topology as well as some insight into any networking hardware you may be implementing in your setup. I would like to understand how your devices are communicating and what tools are being used to make those connections possible.

  3. You mentioned…

“Problem seeks worse than when I installed mR a few days ago, and also seems to be getting worse daily so it should be called frequent rather than occasional dropouts now”

Can you please provide some insight or clarification into this statement so I have a better sense of the, lineage of this issue. Furthermore, do these dropouts seem to be worse or in less frequency depending on the codec + sample / bit rate of the media being streamed?

-Eric

Hi Eric…thanks for responding

My network used to be really simple… Mac’n’Dac [ That is MacMini with Roon Core ) , controlled by laptop wirelessly. When I wanted to add a headphone listening station in another room, wireless was unreliable so I set up a wired ethernet connection to the Time capsule used for backup and for connecting the Mini to the Modem. That worked OK with Rasp Pi, Sonicorbiter and Macbook as Roon endpoints, so I invested in a MicroRendu with UPS power supply, worked even better until a couple of days ago when the audio started to drop out, more and more frequently. Yesterday it had got down to every 15 seconds hence my email…reading other forum posts seemed to indicate a network problem so I have ordered a Netgear switcher…other posts indicated different problems if the drop outs were escalating so i rebooted Roon on the Server Mini and on the remote laptop and that seems to have addressed the issue. I dont know whether it relates to the time that Roon is actually on, because normal laziness means that I dont power down any of the components, just let them go into sleep mode

So, simple equipment description…Modem to Time capsule to MacMini with Roon Core and library on Glyph drive connected to Mini. Microrendu hard wired to Time capsule, remote control via laptop or iPad. Netgear GS 250 arrives tomorrow , plan to connect it to Modem then hardwire Mini, Time capsule and MicroRendu to it. Mini is connected via FireWire to Sanders Electrostatic system, mR is connected to Schiit Dac and Mjollnir headphone amp

After re-booting, ( just turning off not re-installing ) system has behaved itself all day.

I sometimes feel it would be worth a CA article about best practice with Roon as a step up from Mac’n’Dac…I dont know much about NAS etc but feel that would be an obvious next step

and in response to a specific question you asked…I dont think that the problem was related to the bitrate being streamed as it was all 44/16

Hi @diw ------ Thank you for the follow up and taking the time answer my questions. The feedback is greatly appreciated!

I am glad to hear that power cycling your equipment has returned stability to your setup. Please keep me updated on any new observation that are made with the additional equipment being added to your network configuration. If this issue crops back up, I will grab some logs from you to have our developers take a closer look at what may be causing the issue.

Happy listening!

-Eric

started happening again after a few days of trouble free operation…will try power cycling again

Hi @diw ---- Thank you for the feedback. Let me know how it goes after you have gone through the process of power cycling your hardware as I am looking forward to hearing your observations.

-Eric

Power cycling all seems to have cured the problem again…do you think this might apply most to the MicroRendu which I tend to leave on all the time as timing problems build up over time? Schiit suggest the Gungnir DAC should be left on all the time and the computer will sleep on its usual cycle

I leave all of my mRendu setup on all the time and don’t have any issues. Maybe some kind of network issue? I see you ordered a switch; the designer of the mR, John Swenson, recommends using an unmanaged switch (or turning management off with a managed switch).
I’m using an unmanaged switch with my setup.

Originally I used the MicroRendu with the wall wart powersupply…since I got the Uptone UPS I have been using it the mR more but the trouble seems to have started after that point ( hard to be certain about that ) Following some posts on this thread I installed a Netgear unmanaged switch after the Apple Time capsule and plug everything into that. As I said before it seems to occur after some time of operation rather than immediately so power cycling mR, MacMini and the laptop fixes it temporarily…next time it occurs I plan to powercycle each of those things in turn to see if it is one in particular

I have two microRendus with UpTone LPS-1 supplies feeding Schiit DACs (Bimby and Yggy). Connected with Cat 6, Netgear switches and a Ubiquiti EdgeRouter PoE router to an Intel NUC with Ubuntu running Roon Core. Never any dropouts, although Roon Core logs show occasional RAAT “trouble” warnings.

new roon and mr cust…just set up my microrendu and roon …played for a while…then dropped out…now has dropped out 2x now…even when the laptop is hardwired into the router
using my 10 yr old laptop as my ‘‘nas’’

upon when rebooting roon it doesn’t recognize the microrendu at all in my audiophile setup…not showing as a device or endpoint, i guess…even unplugged and replugged in the microrendue and lcaps.

now the microrendu doesn’t show as a device at all in Roon…?..have restarted my laptop a few times, too
(see screenshots please below of both roon and my microrendu)

update…was getting 404 errors etc…so unplugged replugged in
also in the sonore 3 dropdowns, where the top one shows idsd…i instead chose ‘usb’ as device
and it’s working now.