Occasional Dropouts

Sometime after updating to Roon 1.7 I have been getting the occasional dropout for a second or two. I’ve tried everything I can think of. The dropouts do not happen when streaming Spotify. Only Roon.

I run Roon Core on a Small Green Computer SonicTransporter and Roon Ready on a Sonore OpticalRendu. My DAC is an Ayre QX-5. I’ve changed the DNS server on my AMPLIFI router to Open DNS, as suggested on this forum, but that made no difference.

I tried emailing a Roon Ready Diagnostic but received no response. And no response to a follow up email as well.


Hi @Ultrarunner,

Is there any change if you play to a different endpoint, like System Output of a remote device?

Thanks for the quick reply. I’ve set up my iMac Pro as a Zone and will listen for a few hours to see if the dropouts occur. It’s very inconsistent so it will take a while. If this does work, doesn’t this just mean that the problem isn’t with Roon Core on the SonicTransporter? That would still leave the router, RAAT/opticalRendu, or DAC as the possible culprit.

Listening for a few hours on the iMac Pro resulted in no dropouts, so presumably the problem is after the Roon Core machine.

Also, please change my username to Ultrarunner.

You might like to detail the network connections for everything. wifi connections for the core along with streaming and wifi endpoints is possibly what’s going on here.


WiFi is via router only. The core and endpoint devices do not have WiFi. The ST is wired to the router. The router is wired to a switch that sends the signal optically to the opticalRendu.

as it should be so that parts covered.

Hi @Ultrarunner,

If you try connecting your Ayre zone to the iMac instead of using the OpticalRendu, do you see the same behavior that way? You should be able to locate and enable the Ayre in Roon Settings -> Audio once it’s connected to the iMac.

Is this any different than what I tried above? As mentioned, if I bypass the opticalRendu and DAC, it seems to work.

Can someone take a look at the Roon Ready Diagnostic which records the dropouts?

Hi @Ultrarunner,

Before you confirmed that the iMac System Output worked as expected.

The test of connecting the Ayre to your iMac would help clarify if this behavior is specific to the Ayre DAC, can you please give that a try?

I’m not really sure what you’re suggesting. Roon Core isn’t on the iMac. Can’t someone look at the Roon Ready Diagnostic to see if it can help point me in the right direction?

Hi @Ultrarunner,

You can send me the Roon Ready Diagnostic package by uploading it to Dropbox / Google Drive / Send.firefox.com and posting a link here.

I understand that the Roon core is not on the iMac, but if you have installed Roon on it, any device you connect to your iMac should be visible in Roon Settings -> Audio, even when on a different Core (like your SonicTransporter).

My thinking regarding this is to see if the Ayre works as expected via a USB connection to the iMac and does not contain dropouts in general. If this issue were to affect the Ayre via USB as well, it would provide a useful data point.

Here is the link to the Diagnostic pdf:

Ayre doesn’t appear in Roon on my iMac. My DAC isn’t connected to ethernet. The only input is USB (from the opticalRendu). Perhaps that’s why I didn’t understand your suggestion. Hopefully the diagnostic will turn up something.

Hi @Ultrarunner,

Thanks for sending the diagnostics over, I have requested that the technical team look over this.

Hello @Ultrarunner,

Thanks for your patience while we had the tech team look at the logs.

Looking at the diagnostics, it appears that the Roon Core + network are collectively delivering the data to the opticalRendu properly, so lets focus our troubleshooting elsewhere.

We can also see in the logs opticalRrendu is registering the dropouts. However, we cannot ascertain the cause of them with the limited scope of the Roon Ready logset. This would require further logging that captures the state of the opticalRendu’s CPU, USB status, and network stack.

The two most probable sources of the dropouts are an issue with the DAC’s UAC2 USB implementation or the opticalRendu failing to process the audio correctly.

Would it be possible to plug the Ayre DAC into the SonicTransporter to see if there is any difference in behavior? Since the SonicTransporter and the opticalRendu are both running Linux, this should give us some insight into the DACs performance when connected to a Linux USB host.

If playback via the SonicTransporter does not exhibit the dropouts, I would reach out to the Sonore technical team with your findings and continue troubleshooting with them.


Thanks very much for this, John. At least now the problem has been narrowed down to two devices, the Rendu and the DAC. I don’t think there is a way to connect the Sonic Transporter and DAC directly. The only connection is Ethernet to a switch or router.

Sonore wasn’t helpful but I’ll try some other tests, including possibly borrowing another DAC. Thanks again for your help.

Hello @Ultrarunner,

Let us know the results of your continued testing and let us know if you have any other questions!


This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.