Occasionally Can't Connect to ROCK

I just set up ROCK on a NUC7i7DNHE. (The main difficulty was that the picture always extended past the screen, and I had to guess the locations of certain things and follow walkthroughs from the Internet. I think I could have used overscan, but I couldn’t find any remotes.)

At first, it worked great. I was using my iPhone as a remote. But then I got the disconnection messages that were fairly common when I was using my iMac as a core. At first, the remote would reconnect fairly quickly, but then it got to the point where the disconnect message remained for quite a while. (I had to run before I could see whether it managed to reconnect.)

I have connected the NUC to my network by Ethernet. When I used my iMac as a core, I did the same but experienced frequent disconnects. Is there anything I can do to minimize or eliminate the disconnects?

Is it possible that my iPhone remote is somehow trying to connect directly to the NUC wirelessly rather than using my wireless network to connect to the NUC? (I doubt it, as I never set up a wireless connection between my iPhone and my NUC.)

When this new setup works, it seems snappy, so I am hoping to resolve these disconnects. Thanks for any help.

I have this issue when two coress are running on the same network, an iOS remotes. Have you uninstalled your iMac’s old core? Is your iMac on when you experience disconnections with the NUC?

I had closed Roon on the iMac before running ROCK on the NUC. But the iMac remained on and logged in and I did not uninstall Roon from it. I did, however, select a different core (the one on the NUC) when I first connected to Core on the NUC after the Roon Remote asked me whether I wanted to switch Cores. Thanks for your help.

Try restarting your network equipment…and I mean all of it…power it all down for a min or 3 and then power it back up. If this is carryover from the similar issues on your Mac then I’m suspicious it’s a networking issue perhaps

Thank you for the report, @Andrew_Stein!

To start, may I kindly ask that you please provide a brief description of your current setup using this link as a guide.

Make sure to describe your network configuration/topology, including any networking hardware currently in use, so we can have a clear understanding of how your devices are communicating.

As @wizardofoz suggested above, I would recommend power cycling your Core machine and networking hardware to see if there is any improvements here.

Are you utilizing any antivirus or firewall on the Core machine? If so, try disabling.

Do you have any other remote devices that are exhibiting the same behavior? Or is it just this iPhone remote?


Thank you, Dylan and wizardofoz.

After I returned home yesterday, I noticed that Roon was connecting better through the iPhone application. The problem may stem from the iPhone’s own limits, as it seems to crop up most often when I switch to another app and return to the Roon app a few minutes later or when I have not been using the Roon app for a long time. In contrast, I just tried the Mac Roon app, which instantly worked. Both the Mac and the iPhone are connected to the network wirelessly. And that is why I am surmising that the connection problem has something to do with the iPhone, which, I assume, is trying to conserve the battery and in the process is offering limited multitasking and background functionality. But that is just a guess.

I am going to try the Android Roon app to see whether it connects better.

I don’t know whether this issue is related, but I added a new FLAC album to my usual storage place last night, and Roon failed to scoop it up for at least a couple of hours. By this morning, Roon had found it.

Thanks again for everyone’s help.

I find that the iOS devices tend to look like Roon restarts (could be interpreted as reconnects) when not used for a while…like the screen opens then goes blank then Roon logo then music play screen or where one was. Typically when I want to make it happen it won’t but I think this might be what you are experiencing.

I think so. Maybe iOS 12 will improve the issue.