Odd behavior. DR does not show until a track is played

I noticed that most of my albums have no DR value showing. When I started looking at the individual tracks I noticed that only some tracks had a DR value. Many albums have one or two tracks with DR but most have none. What is really strange is that the first few albums in my collection alphabetically have DR on all the tracks after that it gets sporadic.
I discovered that if I play a track the DR shows up after I play it. I made sure that Roon was done analyzing all of my tracks and I even tried reanalyzing some tracks and albums but this did not make the DR appear.

Hi Mark,

Are you sure Audio Analysis is complete?

Go into Settings > Library and check Background Audio Analysis and see if it’s still working.

More info here.

Cheers, Greg

Yes, my guess is that the initial 1.3-triggered audio analysis is still in progress and the DR measurement for the track you played was generated “on demand”.

Thank you very much for the response.No, It looks like my library is done being analyzed. I have been to the Settings > Library screen several times trying to figure out a way to get it to reanalyze my library thinking that would help. Here is a screen shot of my Settings> Library screen.

Oops I didn’t mean to upload such a big screenshot! :flushed:

Hi Mark,

Can you go into the Track Browser and add the DR column? You click the little V on the right side of the screen to activate the drop down and click Dynamic Range.

Then scroll down a bit and show us an example of an album and take a screenshot.

Cheers, Greg

Sure, I had already added the DR column.

Thanks Mark.

Let get @joel back and see if he can help.

Cheers, Greg

It looks like someone else is having the same problem in another thread.

Holy smokes! Bingo! I just tested this with a few files that have no DR value. But when I start to play the file, then check View File Info, DR is now there.

EDIT - the song has to play for at least 5 seconds before the DR value shows up in View File Info.

This is one for @brian.

I don’t know if this means anything but when I first started analyzing my library I was using the “Throttled” setting. After about 5 min I noticed how slow it was going so I upped it to “Fast (4 cores)”. The DR value shows up for all of the tracks on my first few albums alphabetically but then it starts skipping after 5 or 6 albums. Is it possible that changing this setting corresponded to when the tracks started getting skipped?

That is what I did too…not sure if there is a correlation.

There is definitely something strange going on with analysis for me. I just changed my setting to “Fast (One Core)” and picked 9 albums to analyze. it is analyzing over 10,000 files. I assume that the denominator is the number of tracks to be analyzed. I’m going to let it work. Maybe this will fill in the blanks. Oh,also rebooted my core before I started.


More strange behavior…I picked an entire album to play that had no DR values associated with any of the tracks. If I then go to the tracks view and look at that particular album, I notice that the DR value for the next song to be played is already there. For example, if track #1 is playing, both tracks #1 and #2 will show a DR value. Once track #2 starts to play, after a few second the DR value for track #3 will show. If I manually skip to track that has no DR value, then after 2-10 seconds it and the next track will show a DR value.

Mark, just curious if you are still having the same problems?

Ok guys, I need to clear few things to avoid misunderstanding - Roon doesn’t analyse tracks in an alphabetical or any other order, everything is happening randomly (this is to avoid getting stuck on the corrupted track). Whenever you change analysis settings for e.g. from ‘Throttled’ to ‘Fast (1 core)’ you restart the analysis process.

Roon has also a feature which is called On-Demand Audio Analysis. Idea of this feature is the following - if you start the playback of the track which isn’t analyzed, Roon will place it in the top of the list and will start the analysis immediately. So you could get the benefits of the volume leveling and the crossfade for a now playing track.

@tboooe, we’ve analyzed your logs and we aren’t seeing anything strange which can point us to any specific issue. So I want to reconfirm once more - are you sure that Roon has finished all the post-migration procedures ? I.e do you have a spinning circle in the top right corner ? Have you tried to restart the Core ? What happens when you turn off/on the Background Audio analysis ?

@Mark_Umstead - your analysis isn’t finished (10688 tracks to go), so it is an expected behavior not to have a DR for all your tracks.

Also take into the account that TIDAL tracks will not have a DR range because we can’t analyse them.

1 Like

@vova thank you for the reply. I can confirm there is no spinning circle. In fact, when I fist updated to 1.3 I monitored the analysis window to see how long it would take to complete rescanning. After about 15 hours the process completed. I have restarted the Core multiple times. I have tried to force a manual re-analysis of specific albums many many many times but nothing happens. I have disabled Background Analysis, restarted, changed # of cores, etc. The odd thing is I see the Legacy volume analysis data when I look at File Info so at least with version 1.2 there wasnt any issues analyzing my files. Nothing has changed in my network or hardware between version 1.2 and 1.3.

While typing this, I restarted my Core for probably the 10th time since reporting this issue yesterday. The only difference was that I turned off background analysis before restarting. After Roon restarted I enabled Background Analysis. Though there is no circle in the upper right corner, I can see that the background analysis is occuring from the Settings Library page. Now about 34K tracks are being analyzed. Not sure why this is now working.

So my questions are:
Why didnt manually starting a re-analysis do anything?
Why did Roon say it was done rescanning my library yesterday after 15 hours?
What happened when I turned off Background Analysis, restarted Core, and then enabled Background Analysis to initiate the process?

@vova The only reason that my database is not finished is because somehow Roon thought that the analysis was done but it had only done about half of my library. I even checked the running processes and CPU utilization on my core to see if analysis was really done when I noticed the missing DR info. Roon was defiantly no longer analyzing tracks. Somehow analysis kicked back in when I reanalyzed 9 albums. Maybe something happened to my core machine and the reboot helped. When it completes this run it will be interesting to see if the tracks that were missed the with the first analysis will be done. I’ll report back