Oh Dear, oh dear - Roon keeps losing the plot and pausing Tidal music

I am back to where I was 3 years ago. I can play a Tidal album via Sonos but Roon keeps losing the plot and pauses the music, sometimes to restart but often not. A week ago this was not happening. I have not changed my system at all. I think it does not happen when I play from my NAS-based music library but time will tell.


In order for Roon’s @support team to better assist you, please provide a brief description of your current setup using this link as a guide.

Make sure to describe your network configuration/topology, including any networking hardware currently in use, so they can have a clear understanding of how your devices are communicating.

I have 6 zones:

  1. Sonos Play 1 x2
  2. Sonos Play 3
  3. Sonos Play 5
  4. Linn Keltik Aktiv: pre-amp, 4 amps plus Sonos ZP80
  5. Linn Direktor + Sonos ZP90
  6. Linn Wakonda/LK100 +Sonos ZP80

My music library is on a NAS (Linkstation)
Control is via a Windows 10 PC
Everything except the Play 1s is ethernet connected.

The problem has not disappeared overnight. I can still play a Tidal album via Sonos but not via Roon.

Since no answer is forthcoming I will stop using Roon. What a shame.

Hi @Dick_Cooper,

Apologies for the delayed response here! Just to confirm some things:

  • Is the NAS your Core machine or is it the Windows 10 PC? Can you give some additional information about the specs of the Core machine?
  • Can you elaborate on your network a bit? What router is in use? Any other networking gear?
  • Since this started have you tried rebooting your Core machine?


The Windows 10 PC is the core. It is an Asus Vivo running Windows 10 Home. 16Gb RAM, x64 processor.
The router is provided by my broadband suppler Free… There is also a Netgear switch to get it all connected.
I have rebooted the PC several times.

Roon worked fine a week or so ago and I have not changed any of the equipment. It is still the case that I can play a Tidal album non-stop via Sonos but not via Roon

I don’t know if this helps, but I have just been playing a Tidal album via Roon. If it stops playing, which it does every few seconds, and then I restart it from where it stopped, sometimes the little time numbers at the bottom do not change even though the music is playing.

Having rechecked that I can play from my NAS via Roon without problems I thought I would try to reboot the router. Right now it seems to have worked: I am listening to Tidal via Roon without problems. Fingers crossed ! :grinning:

(Later the same day) Unfortunately my finger-crossing did not work and the problem has returned. :disappointed:

I have tried rebooting the router again but no luck. I then tried clearing my browser cache - and that seems to be working for the moment. Do you bright techy people know of anything else I might try ?

Hi @Dick_Cooper,

Thanks for the updates here! Since a router reboot helped temporarily it seems like it might be a networking issue. Have things continued to work okay since the cache clearing though?

Using Google DNS or Cloudflare DNS might help in this case as well — definitely worth giving that a try.

No, unfortunately, back to square one. I thought it might be a lack of download speed with more people logging on, but my download speed (20 Mb/s) remains constant.

Hi @Dick_Cooper,

I think the next step here is to enable some diagnostics on your account — This definitely appears to be networking related in some way, but hopefully our diagnostics can shed some additional light on what’s happening here.

Before I enable this feature, I’d like to ask for your help ensuring we gather the right information.

First, can you please reproduce the issue once more and note the time at which the error occurs as well as which track you’re trying to play. Then respond here with that time and track, and I’ll make sure we review the diagnostics related to that timestamp.

I will do as you suggest.

Sorry to keep you waiting: it’s a sunny day so I spend time in the garden. I am playing a Tidal album that used to stop a lot - but today it just keeps playing !

Hi @Dick_Cooper — That’s great, I’m glad things are working so far! Please reach out if it does happen again. Enjoy the garden :sunflower:

It has, of course, just stopped. it stopped at 1705 local (French) time. I was playing “Sun Ray” by Lenny Marcus and it had reached the track “Stick with it” It stopped 1.48 into the track.

Here is a second example. At 1741, playing Ray Bryant “Golden Hits” it stopped “C Jam Blues” at 3.46

Thanks, @Dick_Cooper.

Now that I have the timestamps, diagnostics have been enabled on your account. The next time your Core is active a diagnostics report will automatically be generated and uploaded directly to our servers

Once that’s been received, I’ll be sure to update this thread and pass the diagnostics over to the team for further analysis.