One computer running Roon Bridge can't connect to Roon Core


I recently purchased a lifetime membership, and I have installed Roon throughout my home. One computer however can’t connect to Roon Core. My system is as such:

Bedroom- 2016 MacBook Pro running 10.12.6 running Roon Core. Mytek Brooklyn, Naim 5i, Dali Epicon 2 connected to MBP. Everything works fine.

Office- 2014 MacBook Pro running 10.12.6 running Roon Bridge. Audioquest Dragonfly Red and Kef XS50 connected to MBP. MBP cannot see Roon Core, nor can Roon Core see Roon Bridge on this MBP.

Living Room- Auralic Aries Mini connected to Roon Core. Mytek Brooklen, Naim XS, Dali Epicon 5 connected to Aries Mini. Everything works fine.

Family Room- MacBook Air running 10.12.6 running Roon Bridge. Meridian Prime, Naim 5i, Dali Mentor 2 to connected to MBA. Everything works fine.

(2) iPad Pro 10.5" with Roon Remote app installed. Everything works fine.

Network consists of 4 Eero’s placed in the office, bedroom, living room, and family room. Each room has a switch plugged into the Eero in that room, and all devices are plugged into the switch. Don’t have any network issues. MBP in office that won’t connect to Roon Core can share screens, access files, etc with MBP in bedroom that is running Roon Core, and vice-versa.

I have tried restarting both computers, uninstalling Roon Bridge from the MBP in office, installing Roon Core on MBP in office and putting into “remote” mode. I have turned off all firewalls & security settings on both MBP’s. All scenarios produce the same result.

Please help me to get the office linked with the rest of the system so that I can start enjoying my Roon purchase. P.S., I have a Synology DS214PLAY+ with all my media on it as well. Would it be better to run Roon Server on this than Roon Core on the MBP in my bedroom, as it is currently set up?

What are your IP addresses for all the devices especially the CORE machine and the OFFICE one. Are any on Wifi?

If you have an iPad or iOS device maybe you can run FING to see if it can see all the machines

Hi @Will_Pisula ---- Thank you for the report and sharing your feedback with us. Both are appreciated, sorry to hear of the difficulties.

Moving forward, I would recommend trying “FING” as suggested by @wizardofoz (:thumbsup:) so we can be certain that the mentioned MacBook Pro is within the same IP range as the other devices mentioned in your post.

Furthermore, you had mentioned that each room has a switch which is plugged into the Eero in that room. Can you please verify the make and model of the switch being utilized in the “office” were the issue is occurring? Also, during your troubleshooting of this behavior, have you tried plugging the MBP directly into the Eero?


The MBP in the bedroom running Core has an IP address of The office MBP running Bridge has an IP address of

Both MBP’s are on Wi-Fi. The brand of the office switch is probably irrelevant, since the office MBP isn’t plugged into it, but it is a 16-port Netgear that’s 3-4 months. I can look up the exact model in my Amazon order history if you think that would be helpful. Haven’t plugged the office MBP directly into the Eero, as that would require a USB to Ethernet adapter (which I have), and I have 2 office peripherals that will only work if plugged directly into the MBP. That is why the MBP is on Wi-Fi even though it sits a few feet from the switch.

Let me know what else I can do to help. Thanks for your help. @wizardofoz

In addition to trying the units on Ethernet (LAN) connections…if that doesn’t work then I suggest you try both on the same switch to rule out any switch issues.

Assuming you are running OS X - do you have all the firewalls off. Are you running any firewall rules in your router?

Can you ping the Core MAC from the Office Mac? From a terminal prompt run “ping”

The do appear from the IP addresses you have given to be on the same subnet. I assume you are also using DHCP for address assignments?

Since both MBP’s are on Wi-Fi, I doubt it’s a switch-related issue. Neither MBP has an Ethernet port, so plugging them into the same switch would be problematic anyway.

I have firewalls turned off on both MBP’s and my router.

I can ping both MBP’s, share screens, access files, etc.

Hi @Will_Pisula — Thank you for the continued feedback!

I see that you mentioned that there are no active firewalls, by chance do you have active antivirus applications anywhere?


No, I don’t use antivirus software of any kind. Again, please remember that both MBP’s can see each other’s files, share screens, etc. Only Roon seems to have difficulty with their connection to each other.


hi @Will_Pisula ---- Thank you for the follow up and clarification.

Moving forward, before we try to gather logs, I would like to verify a few more data points with you. In your first post you mentioned the following:

“I have tried restarting both computers, uninstalling Roon Bridge from the MBP in office, installing Roon Core on MBP in office and putting into “remote” mode. I have turned off all firewalls & security settings on both MBP’s. All scenarios produce the same result.

  • When the office MBP was acting as a Roon remote and trying to connect with your Roon core (i.e “Bedroom MBP”), it failed, correct?

  • When you allowed the office MBP to act the core, could you play music successfully?



When running Bridge on the office MBP, it never “populated” as a device that I could setup on the MBP running Core. The MBP running Bridge said “Running”, but it was in grey if that matters.

When I installed Core on the office MBP, I was able to play music on that MBP off of a NAS that it saw as well as stream Tidal.


Hi @Will_Pisula ---- Thank you for verifying!

If you you still have “Roon” installed on the office MBP after running the “core” test (i.e playing music etc) can you please verify if you are able to connect to the “bedroom core” with the office MBP acting as a remote device?


I don’t have Core installed on the office MBP anymore, but when I did, the bedroom MBP never populated under settings to be enabled. All of my other devices running Roon in the house did show up on the Office MBP however.


Hi @Will_Pisula ---- Moving forward, I would like to grab a few sets of logs from you so our techs can have a closer look into what could be causing this behavior. Please see below.

Set #1 - Roon Logs (from core machine):

  • Please use the instructions found here and upload us a set of logs from your Roon core (i.e Bedroom- 2016 MacBook Pro).

Set #2 - RoonBridge logs:

  • Please locate your “RoonBridge” folder (using the instructions below) and upload us your logs from your RoonBridge computer (i.e Office- 2014 MacBook Pro).

  • Open Finder and click Go in the top bar

  • Hold down the Alt key to unhide the Library folder

  • Click the Library folder

  • “RoonBridge” (folder) - > “Logs”


Here is a Drop Box link to my compressed logs for the MBP running Core and the MBP running Bridge. Thanks.


Awesome, thanks @Will_Pisula! Confirming that the both sets of logs have been received and are in our queue to be evaluated by a member of our tech staff.

Once my report has been updated and passed back, I will be sure to share the team’s thoughts/findings with you ASAP. Your continued patience is very appreciated while our team conducts their evaluation.


Hi @Will_Pisula ---- Just touching base again real quickly, as my techs have asked for some additional materials upon receiving my report. Please see below. Thanks!

  • Please use the steps found in “Set# 1 - Roon Logs” from above to send us RAAtServer logs from the core machine.

  • Screenshot of your “about” page from the core machine. This information can be located by going into “settings” and clicking “about” in the upper right hand corner of the window.



I just added the RAAT Server logs and the screenshot you requested to the Drop Box folder that I linked you to early. Thanks.


Hi @Will_Pisula — Thank you for the follow up, confirming that the materials have been received.

Very quickly, when you took the screenshot of the “about” section on your Roon core was the office MBP in an active state (i.e "The MBP running Bridge said “Running”)?


No, it was not. I just added a second screen shot of the Core MBP with the Bridge MBP active to the Drop Box folder.

1 Like

Thanks @Will_Pisula, I will take a look shortly!