One iPad as a remote, another iPad as an endpoint - problems

I’m using a 2017 15" MacBook Pro for my core. The software is up to date: 10.14.3

Roon version 1.6 build 390 stable 64 bit.

Recently I’ve had a 2017 iPad Pro hooked up to a Parasound Halo P5. I’d control Roon from my MacBook Pro and pick the iPad for the zone, which sent things along to the P5’s dac via Apple’s digital out adapter for the iPad. Everything worked smoothly (for months).

Today I got a 2018 iPad Pro. When I set it up I had it just duplicate the set up on my first iPad Pro, using iCloud. Both iPads are using 12.1.3

The first problem is that while I can open Roon on the new iPad, Roon won’t recognize the new iPad as a zone. I tried various places in Settings for configuring things, but the new iPad didn’t show up anywhere. (The old one didn’t either.)

The second problem is that now, when I pick the 1st iPad as a zone and try controlling it from either my laptop or the new/2nd iPad, things start okay but then break down in less than one track. Wether I’m running things from the new iPad or running them from the laptop with the new iPad off, Roon plays less than one track and then skips to a new track and then, before that track even starts playing, Roon skips to a new one, and then does the same thing, over and over. If I hit pause during this process it pauses for a split second and then starts jumping through tracks again. Then it stops and says “Nothing Playing”. Sometimes I get a message that Tidal is loading slowly, but I don’t think that’s really the problem, because (i) if I pick System Output (the laptop) for the zone, then everything works fine and (ii) if start music on the Tidal app on the 2017/old iPad Pro, then everything goes fine. So something is going wrong with Roon and the two iPad Pros, and I don’t seem to be able to go back in time by turning the new iPad off and using the old one as the zone (which is what used to work).

One potential problem is that on some Apple menus, both iPad Pros have the same name, and it’s only when you dig into the menu that you get a “(2)” after the name of the new iPad Pro.

At the moment I don’t have a workaround; picking the 2017 iPad Pro as the zone is how I get music over to my main audio system, and I need that to work while both my laptop and new iPad Pro are on.

Any thoughts on what the problem is or how to fix it?



The new iPad Pro finally showed up as a device on the network (and with it’s own name) and I enabled it in the Audio part of settings. After playing a few seconds of a track it started the jumping thing and then went to “Nothing Playing.” This time Roon gave a message saying that audio is loading slowly and that that might be a network or a hardware problem (or something like that).

But if I open Qobuz and play directly from that app, then everything goes fine.

Also, after I switched the new iPad to Qobuz, Roon recognized the old iPad. I haven’t yet seen it recognize both at the same time.

The problem goes away if I shut down Roon on the new iPad and restart Roon on my laptop (the core). At that point I can use the older iPad as an endpoint and it works normally.

I could also use my iPhone as a remote to control the iPad as an endpoint.

But within five seconds of opening the Roon app on the newer iPad while the older one is playing things went haywire in the usual way. Is that a bug or does the system standardly not accept one iPad as a remote and one as an endpoint?

Hi @Brad_McHose,

So we can better assist you, please describe your network configuration/topology, including any networking hardware currently in use, so we can have a clear understanding of how your devices are communicating.

I’d like to enable some diagnostics on your account, but first I was hoping you could reproduce the following steps and make a note of the time for each:

  • Shut down Roon on the new iPad, reboot the Core machine.
  • Play to the old iPad like normal.
  • Open the Roon app on the new iPad.
  • Make note of when the problems occur and any error message that appears.

With the above timestamps (please also include your timezone) I can enable diagnostics on your account so the team can take a look.

Hi Dylan,

Thanks for your reply. I managed to fix it myself just now. I thought that maybe Roon was getting enough control of the new iPad and was curious about the new iPads settings for Roon so I went to look it up in the list of apps and noticed that it wasn’t even there (even though it was on the new iPad and would open). So I tried deleting it and downloading it again, and that did the trick. It now shows up as it’s own zone with it’s own name and I can control the old iPad (which is serving as my “streamer”) from it. So all’s well!

Thanks for your help.



This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.