One tiny click sound at first song after power on RME ADI2 DAC (Ropieee/Raspberry 4)

Situation (Ropieee/Raspberry 4):

When I power on the DAC, its initial position is 768Khz. Then I play the first song on my Raspberry Pi 4 B and hear a tiny click right before the song starts playing. Most of my music collection is 44/88//96 so there’s always a sample rate switch. I tried experimenting with the resync values, but it doesn’t solve the clicking sound. With my Raspberry 3 with Digiberry+ and SPDIF there is no click but when I use its USB connection I do hear it, so it seems related to the USB connection. I’ve asked around on the RME forum, and Matthias from RME said a click could always happen with a sampling rate switch.

Is there anything else I can try? Of course it’s not important at all, but I’m just curious whether it could be solved with a setting in Roon or Ropieee.

Try playing around with Roon’s ‘Resync Delay’.

Ow… you already did that I see…

That’s about the only thing you can do about it. It’s up to the vendor to fix the issue on the device side.

Matthias’ exact words were

A sample rate change can always cause a click, and the reason behind it can be different things. As you can easily try yourself, changing the sample rate as such does not cause a click, so most probably there comes a bunch of resetting/initializing data in that ‘first play’ moment that cause this.

Indeed, it does not happen changing songs afterwards. I can switch from 44 to DSD to 96 without any clicks (even with a resync value of 0ms) so it’s only the initial first play moment.

Using Rock into my RME can’t say I have noticed any clicks at rate changes. Not that I have anything that high. I never turn the DAC off so not sure that’s anything to do with it.

There are no clicks after it’s turned on during sampling rate switches. Could you, to test this, turn it off and on again and see if you hear a click just before it starts playing?


My connection is over USB as well. However, the only time I hear clicks are from the device itself and occur during large volume changes - and those are normal.

Are the clicks you hear over headphones or from the device itself?

Why the initial setting at 768Khz? On my RME the initial setting depends on the last used setting; e.g., DSD256/128/64, ->705.6, 352.8, 176.4, respectively, and 96/88/48/44… You might try and adjust the initial setting so it is not fixed at a rate as this may cause extra work akin to what Mattias said.

No, it’s one (1) digital click (audible through amp and headphone) only when the first sound is played, not the mechanical relay switch in the device itself. No digital clicks happen after this initial click.

After turning the RME on (from standby) the initial setting is 768kHz, I don’t think there’s anything you can do about it. RME processes what it receives. Of course the split second after you hit play it changes to 44 (or something else).

The click does not always occur btw. It’s hard to predict when it does. Sometimes I think it’s a timing issue, hitting play too soon. Today I turned on the set, waited about 2 minutes, and there wasn’t a click.

OK, did a little test with the sample rate conversion DSP in Roon (which I just discovered). When I set it to maximum PCM rate it plays everything at 768 and the initial click is gone.

I’m not sure whether the click is important enough to me to turn on this setting though. :slight_smile:

What also remains a mystery is why it’s only a problem initially on startup. After this startup click, it’s possible to switch to all kinds of sample rates without clicks.

1 Like

Interesting. I’ve not heard the click.

I unplugged the USB from my ADI and it still starts at 44.1. I tried it on a variety of different settings, and no change. However, if I am using software it resorts to the last frequency of the last music played; e.g…, a zone in Roon.

Strange. Did you turn set it to standby and back or just unplug the USB cable? This is a ADI-2 DAC FS with the latest firmware, btw. I actually have two of them, and they both behave the same way.

The former and I have the same model as you - the FS. I updated the firmware and driver when they came out last month (9/17-18). And reinstalled them again this AM due to a BSOD that I had. - so they are up to date.

To follow up on what you said, I turned mine on for the first time and after reinstalling the dirver and firmware and it came up with 352.8 for the INT rate. When I looked at the driver of course they matched.
As soon as I played some music through it went back to its usual behavior - keeping the last settings.

I have no idea why yours are different. I only have the one so I have no reference. It would be great if I could reset they whole thing back to factory defaults, but I haven’t figured out how to do that yet…

Let me know if you’ve discovered it.

I appreciate your efforts, but please don’t reset to factory defaults for a stupid little click I am hearing! :smiley:

When I read BSOD I’m thinking Windows and a PC. I’m on a Raspberry Pi 4B.

LOL, it would not be just for you - I’ve wanted to reset to factory ever since I received it. That would give me the option to start seriously playing around with different settings. I want to try setting up some different profiles.

Correct on the BSOD, hardware and OS, pi is much safer I have a few of them running as bridges feeding speakers and remote listening. My pc as core feeds the bridges over wi-fi and other DAC/Amps over USB, including the RME. So that likely is the reason for the differences we see.

My remote listening post consists of a pi4 over USB to khadas TB then to JDS Atom amp.

If you have not tried out the remote settings RME has for the smart logitech remotes, you might give it a go. Its been a great help in setting things up.

Its clever and avoids having to use the menu system they have; it has the unfortunate downside of encouraging me to play with settings, which I do, hence the request for the factory reset.

1 Like

Yeah I’ve been a Logitech Harmony fan for a very long time now. I can’t go back to 6 remotes really. :smiley: And my wife would kill me.

Yes indeed, the RME menu can be a bit difficult, and sometimes a factory reset is the only way to get back. The remote makes stuff much easier. Also to figure out whether you actually hear filter changes or the effects of your eq adjustments in listening position.

1 Like

I actually just installed my brand new RME ADI-2 DAC and did a bit of experimenting. Currently, my set up looks like this:

PC (Windows 10) -> RME -> Line Out -> THX AAA 789 (balanced input) -> Headphones (balanced out)

I first started with the default USB compliant driver which worked fine. I then installed the latest drivers from the RME website. The installation installs two sets of drivers: WASAPI and ASIO. I found that the RME WASAPI driver will lock to whatever frequency is set in Windows. T

he ASIO driver, on the other hand, will allow the RME to update to lock to whatever frequency is fed to it (assuming you are not doing any DSP upsampling in Roon).

I’ve settled on the ASIO driver as it allows me to set the DSD Direct and allow the RME to process native DSD straight to the line out.

I guess the thing I’m trying to ask is: Are you using the RME WASAPI driver or the the RME ASIO driver?

No. This post is in the Ropieee section and only pertains to setups involving a Raspberry Pi and Ropieee.