Ongoing connectivity issues with TIDAL

I’ve had ROON for over a year now and it has worked flawlessly – including TIDAL integration – until recently. Following the update to Roon 1.3, I have had ongoing issues with connectivity to TIDAL.

Firstly, my setup: ROON Server (1.3 Build 208) is running on an Intel NUC (Windows 10 64bit) hardwired to the network router. The same router is connected to a Devialet integrated amp. I use either a laptop or a Surface Pro 3 as Roon clients – everything is on Windows 10. The problem described below occurs regardless of whether I am using the laptop or Surface Pro 3 remotely, or using Roon client software running directly off the NUC that also hosts Roon server.

Essentially, after a random amount of time, but typically less than one hour, I notice that I can no longer play any TIDAL tracks. I receive a “TIDAL: This track is not currently available from TIDAL” error that appears at the bottom of the screen for 1-2 seconds. This occurs for any track I select on the TIDAL service even though the track does, in fact, exist on the TIDAL service – as evidenced by successfully playing the track using the native TIDAL app instead of ROON.

I attempt to logout and then login again to the TIDAL service through ROON and I’m then met with a “Network error: Please check your connection”. This occurs despite using the correct username and password. Restarting ROON does not resolve the problem. The only resolution I have found – which is only transient – is restarting the NUC or quitting and restarting ROON Server several times. This will allow me to login to TIDAL through ROON successfully. But, soon enough, I encounter the exact same problem. It seems that ROON is, for some reason, disconnecting from the TIDAL service and then subsequently refusing to communicate with the TIDAL servers for login authentication.

I have tried reinstalling ROON server on the NUC several times but the problem persists. Suffice to say that ROON is useless to me in the current state. Any help would be greatly appreciated. @support

Seeing same problem here with Roon 1.3 (208) running RoonServer on sonicTransporter to microRendu. For me, this is has only been an issue since the 208 build was installed. TIDAL works fine when used directly. I’ve now logged out of TIDAL in Roon and logged back in, it is working for the moment…

Hi @Al_Abuzeid and @C_B — thank you both for the reports and my apologies for the slow response. I would like to grab some logs from you both so we can take a closer look at what may be causing this behavior to occur but before I do that may I kindly ask you both to please provide the following information:

  1. Please describe your network configuration/topology as well as providing insight into any networking hardware you may be implementing in your setup. I would like to have a clear understanding of how your devices are communicating and what tools are being used to make those connections.

  2. In both reports, there is mention that this behavior was not observed pre-1.3, has anything changed in either of your setups (besides the update) since noticing this issue? Not detail is too small.


Hi @Eric ,

Thanks for the response. My network topology is relatively straightforward.

I have an ASUS RT-N56U router. This is connected via ethernet (Cat 6) to a QNAP TS-453Pro NAS with 4 GB RAM. This hosts my music files. Additionally, I have an Intel NUC 5i5RYK with 16 GB of RAM and a Samsung 850 EVO 250 GB M2 SSD hosting Roon server as well as the Roon database. This too is connected via Cat6 ethernet to the router. A Devialet D200 amplifier is wired via Cat6 to the router as well. Lastly, A Verizon FIOS modem is also connected to the router. There a few devices connected to the router via Wi-Fi: a Playstation 4 and, on occasion, one of two Roon Remotes, a Microsoft Surface Pro 3 i3 with 4 GB RAM and/or a Lenovo Thinkpad X220 with 6 GB Ram. All devices are running the latest build of Roon.

Typically, I will call up the ROON UI on either the Thinkpad or the Surface Pro. Roon Server is, as I mentioned on the NUC. Tracks are output via the Devialet Air application (version 3.0.2 Release Candidate), also on the Intel NUC, via ethernet to the D200 and onwards to the speakers. For maintenance, I will remote into the NUC from the Thinkpad or the Surface Pro using Teamviewer v11.0.66695.

I hope this helps.

1 Like

Hi @Al_Abuzeid ----- Thank you for the feedback! I have sent you a PM with instructions on how you can send logs over to us for review.


Hi @Eric – I’ll grab logs as soon as the issue occurs again!


1 Like

A post was split to a new topic: Slow Performance on Windows 10 NUC