Ongoing issue with iPhone remote

I know this has been gone over before ad nauseum, but I can’t find any relevant posts that help:
I’ve always had this issue where my iPhone remote will lose connection to the core every few seconds or minutes at random, giving the dreaded Lost Connection! message for between 5 and 30 seconds. At first I thought it was my older iPhone 5, but it persisted when I upgraded a year ago to iPhone 6S. Then I thought it must be my ancient iMac, but now I have a (slightly) newer iMac and it still happens all the time.

Wifi is strong, with the remote in a room between the router and the iMac (no possibility to wire the iMac, sorry). The phone is set to never sleep, and the Roon app is always in the foreground when this happens. No audio dropouts occur, just loss of control over what’s playing.

iPhone 6S running iOS 13.6

Screen Shot 2020-08-24 at 7.40.25 PM

Wifi is over 2.4gHz, getting DL speeds between 50 and 100 Mbps

Roon is always the latest build.

Thanks for any tips on how to solve this!

I’ve moved it to support.
I’d try moving the iMac to where you can plug it in wired just temporarily. Reboot everything then test to see if connections work.
Whatever that outcome is will give a basis for future troubleshooting.

1 Like

Thanks, tried that (painful as it was), not much changed. The remote connection seems to drop very randomly, and almost with malice-- it will be fine for many minutes, then when I want to change what’s playing it will magically lose connection just before I pick it up. It matters not if the iPhone is plugged in to a charger or just running on batteries, or where it is in the room (at the desk or on the couch a few feet away).

Again, the music never drops out, regardless of whether it’s stored on the iMac’s HD or streaming through Tidal or Qobuz, so I doubt it’s a wifi or internet issue. (The TV is also in the same room as the remote, connected via wifi, and it behaves pretty well most of the time.)

Any other ideas? Are there any settings I could possibly check anywhere?

Forgot to mention: I tried turning off the Mac’s internal firewall, it made no difference either.

Hello @Chris_Berens, what if you switch to the 5GHz band? Any difference there?

Yes! That helped solve it, but sort of backwards:
I actually never set up the 5G on this new computer, because it’s too far from the router. So, I thought “I’ll try it, but it will be garbage.”
Imagine my surprise when both my phone AND the computer were on 5G! (No idea how they got that way.)
When I put them both back on the 2.4G connection-- Bam! No more dropped connection!

Needless to say, I have told both to forget the 5G connection. If I find them on there again, I will change the password.

Many thanks for your help!!

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.

Hello @Chris_Berens, glad you found a solution! I recently had my Chromecasts do the same thing, they’re also now banished from my 5G connection :stuck_out_tongue:

Please let me know if the issue returns, we’re happy to help!