Onkyo NS-6170 - Rate conversion

@support ,
I’m using an Onkyo NS-6170 connected to a Chord QUTEST via coaxial in all the configurations a downsample is applied as in the picture.

Chromecast devices that don’t report their high Res capabilities properly get a generic signal sent to them which tops out as in your screenshots.

Hi @Luciano_Ghinelli1,

It appears that you are using the Chromecast protocol to stream to the Onkyo instead of sending the stream to the Qutest as an endpoint and this has some sample rate limitations.

Can you please provide a screenshot of your Roon Settings -> Audio Tab?
It should look something like this:

Here you should be able to enable the Qutest as an audio zone and then you can select it from the zone picker on the bottom-right hand of Roon:

I would also make sure that the Qutest is powered on and has the proper settings to output to the Coax and that the Onkyo has the Coax input selected, so that the Roon stream reaches it. Hope this helps!



You wrote that you are using a Chord QUTEST connected to your Onkyo receiver with a coax cable but the Signal Path images you posted show you are casting to the Onkyo. Are you sure you selected the QUTEST as your output device in Roon’s Settings / Audio?

I have a Pi with a Digi+ Pro HAT connected to a Sony receiver ( which supports Chromecast ) and when I stream to it this is the Signal Path I see:

I don’t know much about the QUTEST ( I checked and it does not appear to support Ethernet or WiFi ) but I would have expected to see it in your Signal Path not the Onkyo.


The way this is being configured, the Onkyo is all that Roon can communicate with. The Onkyo is not Roon Ready so it communicates via Google/Chrome Cast. This appears to be limited to 48k 24 bit. For full HD capability your best option is a UPnP Bridge unless Onkyo are considering making their device Roon Ready. Otherwise you have to stick with the Onkyo native app.

I agree with Henry that the problem is caused by Onkyo not being Roon Ready.

I think the easiest solution requiring no extra purchase is to plug the Qutest directly into the Roon Core machine, bypassing the Onkyo.

Your signal path doesn’t show the qutest as a Dac

Wouldn’t the best route be core> qutest > Onkyo by Analog

Presuming the Qutest is the better dac and the one you prefer to use

This ties in with the @noris comment above

@noris I finally figured out the reason for inconsistent replies here. The Onkyo NS-6170 is not a receiver. It’s a network player/DAC without coaxial input and without analog inputs.


Edited once I realized I misunderstood the order the equipment was hooked up. It’s NS-6170 to QUTEST which I got backward somehow :sunglasses:

Based on the specs for the NS-6170 it appears to me that he can’t play hi-res content from Roon to the NS-6170. His only hi-res options seem to be streaming Tidal MQA content using the NS-6170’s built in Tidal client or playing hi-res files on USB storage attached to the NS-6170 using the NS-6170’s built in player.


Hi All,

You do indeed seem to be correct here Peter, I just looked it up myself and it appears that the Onkyo is only an endpoint without any inputs, so streaming high-res to the Onkyo then feeding it into the Quetest is not possible. Since the Onkyo is also not Roon Ready as mentioned by others in this thread, the only way to get the Roon Stream to output to the Onkyo would be through Google Cast as you have shown in the first screenshot.

If the Qutest is located in another room and you are simply using the Onkyo as a network bridge, you might want to look into adding a Roon Bridge endpoint that can provide the Ethernet -> USB connection and that does not use the Google Cast protocol, some popular options include Allo USBridge or Sonore Micro/UltraRendu. Adding one of these to the chain should give you the higher sample rates you want to achieve.


Hi all,
currently, my roon core is in my (home) datacenter so I can’t connect my qutest directly to the pc, other option using is CCA but limited 24/96. I read somewhere I cannot use UPnP/DLN with roon but not sure.
Using Qobuz app able to play stream 24/96 through Onkyo

Hi @Luciano_Ghinelli1,

That is indeed correct, UPnP is not supported in Roon, so you would have to use a Roon Ready network endpoint to feed the stream into the Qutest. As I mentioned before, this Roon Ready endpoint can be a Sonore Micro/UltraRendu, a Allo USBridge or a Rasberry Pi endpoint running Ropieee or DietPi.

There are a few options here, but they all require a new piece of hardware since the Google Cast protocol is limited in the sample rate output. If you’d like the opinions from the community of their experience with these network endpoints, you can most certainly ask in the Roon Software Section of Community.


ahora cambio!!! sin perdidas chromecast NS-6170

@eduardo_fuentes Hi Eduardo - can you tell me whether the Onkyo is able to perform the final unfold of MQA with this set-up and you’re getting 192kHz? Is there any indication from the Onkyo itself?

If it were, it would show in that signal path.

Uh… got my hopes up there for a moment.

Hello @Stuart,

As far as I’m aware, there are no Chromecast devices which accept MQA via the Cast protocol.

The screenshot that @eduardo_fuentes shows above indicates that there is MQA Authentication occurring in the stream, but not necessarily MQA Decoding/Rendering, Roon just certifies the stream as MQA compliant.

What you can do with Chromecast + MQA content, however, is have Roon perform the MQA first stage decoding, which can be achieved by turning on MQA Core Decoder for the zone in the Device Setup tab.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.