Online Music (Radio, Qobuz) does not play

Roon Core Machine

Apple MacBook Pro

Networking Gear & Setup Details

DSL Net, Core connected to Router with LAN cable

Connected Audio Devices

Linn Majik DSI, Sonos
, all via LAN cable to router

Number of Tracks in Library

30000 Tracks

Description of Issue

I‘m new to Roon and started my subscription 2 days ago. Connecting to my library on SSD worked quite well. Can play all this music. Only issue: sometimes the screen stops showing progress, gets stuck with old titles. Biggest problem though is that I can‘t play Music from online sources, e.g. Radio and Qobuz. Alle Information is shown (station name, album, titles, …), but it won‘t play.

Make sure roon exceptions are in the mac firewall

Hi Max,

Just a question to help clarify things for support (fellow user here).

These old titles the playback gets stops in the middle; these are local files and I take it that this is a different issue than being able to play from online sources?

And the issue is playing to the Linn Majik. What happens if you instead play to the MacBook pro? Do you get the same results?

1 Like

Hi Rugby,
Thanks for the additional questions. These will most probably make the problem more precise.
The local files get played perfectly, only the screen does not always show the correct title and time (seems to get stuck).
I tried to play to the MacBook Pro and also 2 Sonos systems I have. Same problem everywhere. Local music gets played, but not music from the internet. But for all music (including from the internet) all metadata is correctly shown (album, titles, cover, …) I can also select individual titles to play - they simply don‘t get played.
Thanks again Rugby for your great questions.

Problem has been solved. I disconnected my MacBook from the LAN cable. Strangely enough, via Wi-Fi everything works perfectly, even HiRes music.

Hi Max

I’m glad you have gotten things working. However, I’m still curious about why that works.

If you don’t mind, what router are you using?

1 Like

Hi Rugby,
Honestly, I was surprised, too. Thought that especially for HiRes content you need a cable connection. My router is a German standard product: Fritz!Box 7520 RN. Nothing fancy.

Need is more like highly recommended.

Hey @Max_Haege,

Welcome to Roon Community! I’m sorry to hear you’ve been experiencing playback problems, but we’re thrilled the issue’s been resolved for now.

As @Rugby pointed out, it’s highly curious that switching away from a wired connection would solve the issue, as the Ethernet connection is more stable and the preferred method for linking to the router.

If you’d like to continue investigation what went wrong, it would be helpful to also know the following:

  • What operating system are you running on your MacBook?

  • Have you encountered other issues with a LAN connection on this laptop outside of Roon?

  • If you’d like to continue investigating, our team would be happy to review your logs to trace down the problem. You can access Roon logs on your MacBook by following the instructions in this Knowledge Base article.

You’ll then use this link to upload logs for our team to check:

Let me know if you’d like to proceed, and we’ll keep tracking down the problem.

1 Like

Did you try a different cable?

1 Like

The problem could very well be the cable. I have not yet tried a different cable as the wireless solution worked. I will do so, though and report back

Hey Connor,
I had the problem with all network traffic, not just Roon. I will try a different cable now and then report back.

1 Like

The problem was not the cable but the socket. This one socket does not seem to work. I connected the MacBook to a different socket and it works now very well - with and without cable.
Thanks for the support to everybody


This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.