Only partial access to music library

Roon Core Machine

Dell Windows 11 Pro
|Processor|12th Gen Intel(R) Core™ i9-12900 2.40 GHz|
|Installed RAM|32.0 GB (31.7 GB usable)|
|Device ID|870CBE35-720D-4779-BA03-0108C010D9D1|
|Product ID|00355-60778-30419-AAOEM|
|System type|64-bit operating system, x64-based processor|

Networking Gear & Setup Details

Nucleus wired to ATT router with Ethernet cable

Connected Audio Devices

Audio speakers for computer. Audio is not a problem.

Number of Tracks in Library

12,000 total tracks.
11,000 of these are local, in my MUSIC folder on the XPS computer
1,200 tracks are purchased from Qobuz
Total library: 12,282

Description of Issue

I have a 4TB Nucleus (purchased July 2021) that is hooked to my Dell Windows 11 Pro XPS computer(see specifications above) via an ethernet cable to my ATT modem. Wi-fi is broadcast to a two story house. There are two extenders, including one in my upstairs bedroom.
The nucleus is wired via Ethernet to my ATT modem.

My system worked fine until June 23rd when the OS became corrupted. With the help of Dell support, I installed a new OS, and restored all my data. The time came to rebuild the ROON system.
My music folder is local, stored on my XPS computer. There are about 11,000 tracks in that folder. I am also a member of Qobuz. I have purchased about 1200 tracks from Qobuz, so my total library is approximate 12,000. See screenshot of ROON software with the FULL library.

However the SIZE of my library on my XPS computer kept changing between, 12,000 tracks and 1,200 tracks. I was able to get STABLE access to the FULL library by checking ONE additional SMB box, in the Windows Features On and OFF area. See screenshot. When I clicked the SMB DIRECT box, then the Roon software consistently showed my full library, of 12,000.
Windows features -SMC -5 boxes, including DIRECT

So far so good.

The problem is that I want to have access to my FULL library on two external devises: my Android Moto G 6 phone, and my Google Pixelbook Go laptop.
When I installed ROON Remote software on both my Moto phone and my Pixelbook, and used these devises UPSTAIRS, Roon reported that my library had only 1200 tracks. See screenshot.

Wifi problem?
When I brought either my Moto phone or Pixelbook downstairs, and literally sat in front of my computer, then the ROON software would change/pop, announcing that the FULL library of 12,000 tracks. This made me think that the problem was with the WiFi coverage in my house.
I contact my ISP provider, ATT, and they upgraded my router. The new router improved the WiFi speed i25 to 33%. Using a WiFi Intensity app, the signal STRENGTH to my Moto phone is -58dMb upstairs (Strong signal) and -34 dBm downstairs (Excellent signal). When I stand in the living room, just 20 feet away from the XPS computer, the WiFi signal is -47dMb, even so, the Roon software says I have only 1200 tracks. I need to sit DIRECTLY in front of the computer (signal -34dBm), opening and closing ROON remote multiple times—then, and only then does my Moto phone see the FULL library of 12,000 tracks. This leads me to believe that it is NOT a Wi-fi problem but a NETWORK problem –the Nucleus and my XPS need to have a stronger connection.

Please let me know what I can do to troubleshoot more. I am a network neophyte.
Thanks for any and all help.

These devices are just remotes (much like remote displays) for your Roon Core they should show exactly the same amount of albums and tracks as you see on your computer. When installing Roon again on your computer, you likely set it up as your Roon Core instead of connecting it to your Nucleus Roon Core?

On your computer, open Roon then Settings from the main menu. Click on X Disconnect (top right in the ROON CORE frame) here and post a screenshot of the new screen here please to confirm this suspicion.

Note: You can do this on your other remotes (Moto phone and Pixelbook) too. Please make sure that all your Roon Remote devices are connected to the same Roon Core, the Nucleus I assume.

Thanks for the suggestion. See two screenshots.
I need explicit help if I need to start from the beginning.

Thank you for the screenshots. From them it is clear that you only have one active Roon Core – your Nucleus. You should now connect to it (again). Next that needs clarification seems to be the location of your music library.

Users of Roon Cores with internal storage usually use this for their library, but you wrote:

Can you please send a screenshot of Roon’s Settings|Storage screen?

I apologize if I used inexact language. I’ve uploaded the requested screenshot.
Thanks so much for your help!

This look good as well. So no obvious misconfiguration.

Your Roon Core holds the central database, containing all the albums/tracks he can currently see. You should see the same numbers in Roon, no matter on which device (PC, phone or laptop). Only thing I can think of is that a big part of your library becomes unavailable for the Core because the PC that hosts it enters some power saving state. Do you lose track counts in Roon when the PC monitor goes blank? Does track count go up again if you access the PC again? If yes, you might want to check your Windows power settings and settings for the network adapter(s) as well. Please tell us your findings.

This is all I, as just another Roon user, momentarily can offer. If you still have issues, try to find a pattern while you wait on official support or another user with an idea.

Thanks for your help.
This partial library problem has been going on for approximately one week. This morning, I discover that all three devises-my computer, and phone and laptop have the error that my Qobuz login has failed. The library has shrunk to a mere 10 tracks. Note: I do have one album with 10 tracks that on an external drive, attached to the Nucleus.
Of course I needed to re-enter my password for Qobuz. I expected that I would need to REMAP my music folder (as I’ve often had to, every month or so), in my original configuration (where I never had the partial library problem.) To my surprise as soon as I re-entered my Qobuz password, the computer immediately recognized the FULL library of 12,000 albums.

To answer your question about the computer power useage: it does go into sleep mode, but when it comes out, I always see the FULL library, when it wakes up. Remember I had to set the SMB setting to DIRECT–before that, the computer was not stable; sometimes my libary was 1200 and sometimes it was 12,000. As soon as I clicked the SMB DIRECT box, the computer ALWAYS reports the full library.
I am aware that you are a ROON community member, and I heartily thank you for your input.
Question: will Support come to my rescue at some point?
I sense that the system is not correctly configured.

Thanks so much!!

As you wrote, the 10 tracks local to your Nucleus Core.

So most likely the 10 tracks from the Nucleus and the ones from Qobuz, judging by the figures you provided.

To get that, all the configured sources (local [to Nucleus], remote [Dell XPS] and Qobuz) must be reachable.

From your description it seems to be apparent to me that your Dell XPS is the primary source of the issue.

As expected so far and not an issue if you allow the Dell to go into sleep mode.

What SMB Direct is meant for: Improve performance of a file server with SMB Direct | Microsoft Learn
I highly doubt that any of your devices meets the hardware and software requirements for that feature. So why is there a setting for it in Windows Pro? Because Microsoft added “SMB Direct client support in Windows 10” at some point. It is unclear to me what exactly Microsoft means with “client support”. I can only guess that as an effect of it, some/all power saving options of the network adapter get disabled (and maybe even some of the system power saving options).

While it seems to be a rather unconventional way to do it – if it gets you the results you need, who am I to judge. But if it works for you with that setting, then why the post here as it seems your problem is solved.

If the post reaches the top of their queue and it looks like there is still need for intervention, they will chime in. Please keep in mind that Roon support staff is primarily here to help users with Roon issues though. There is probably not much they can do to resolve users more general computer hard- and software configuration problems.

From your earlier issue description, it’s seems that the Dell XPS stops to communicate with the Nucleus unexpectedly (by the user).

I personally would disable the “SMB Direct” Windows feature and as I already wrote, check the Windows Power Options (Control Panel | Power Options | Change Plan Settings | Change Advanced Power Settings) and the network adapter options (Device Manager | System | Device Manager, expand Network adapters and right click on the network card and select Properties, go to the Power Management tab) for conspicuous settings that may lead to unexpected loss of (network) communication.
An even better option might be to use the internal (4TB) and external (you claim to have connected) local storage on the Nucleus to hold your music library. In this case you would be free to choose a power plan of your chosing or even turn the Dell XPS off completely and you would still be able to use your entire library with Roon (controlled by phone or laptop).

Although my Roon works fine using the computer alone, I REALLY like accessing my FULL library from the rest of the house, especially upstairs. So the problem is that I don’t have STABLE access to my full libary from my phone or mini-laptop. I get it that Roon support won’t be excited to try help with devise connections. Like you, I suspect setting on my computer are the cause. I do have access to Dell Support and I will approach them with your ideas about disabling the SMC Direct box, and checking out power settings.
Thanks so much!

It is an interestng suggestion. Sounds like you think it would work. The downside is that each time I add music to my library, I have to manually copy and paste it to my Nucleus–a bit of a pain.

Anyway, I’ll be contacting Dell viz my XPS dropping out of the network, as the current leading hypothesis. Thanks so much!

I would agree with the suggestion of @BlackJack. Given that you have the space on the Nucleus, it would be a shame not to use it.

The following article explains how you can move your music:

You could also explore some solutions that automatically copy any music you add to your windows folder over to the Nucleus.

For best results…

Nucleus is your Roon core. Connect it to your network by ethernet.
Install your 4TB SSD music drive inside Nucleus or attach to Nucleus by USB.
Use Dell, phones, and tablets as Roon control devices. They will all see the same thing, ie. your Nucleus.

EDIT: Attach a second HDD to your Nucleus by USB for doing automatic Roon backups per a schedule you establish in Roon.

EDIT2: Do this.

Actually I do have a Toshiba external drive attached to my Nucleus by USB, that I use for backups.

Thanks for your help.

1 Like

Update July 23, 2023

I went to Dell. They changed a setting on my network adapter, enabling a “throughput booster”. They also reinstalled several drivers, to ensure that they were not corrupt. Unfortunately there was no change in behavior–namely I still see only 1200 tracks on my Devises after a half hour.
Taking a page from BlackJack’s line of thinking viz power settings, I eliminated the SLEEP mode completely, setting it to NEVER. Voila—I am able to communicate with the Nucleus (ie. Get full library on both devises, as well as computer) for over 24 hours. So I have a work-around, which pleases me.
While working with Dell, they suggested that after reinstalling various drivers, the next step would be uninstall and reinstall Roon software. I did that today. I uninstalled completely using Revouninstaller. Rebooted and then reinstalled. My music library path was set as before. All 12,000 tracks were shown on the computer and my devises. However within 15 minutes of forcing my computer into SLEEP, my devises showed only 1200 tracks.
Logically, then, this is a hardware problem with the XPS, since a fresh install of the Roon software didn’t help.
Before I go back to Dell, it occurs to me, that in the big June meltdown, something might have been corrupted on the Nucleus (given that different external drive died at the exact same time).
If so, what are the next steps I should take, to ensure that the Nucleus is running properly. See the attached “back door” screenshot.
I absolutely welcome guidance and advise.
Thanks in advance.

Note—using Nucleus alone (to store my music) doesn’t seem an option UNTIL I have stable communication with it from my devises. After all, when 1200 tracks are reported, this is from my Qobuz library, and the other 11,000 tracks (which, as proposed, would be ON the Nucleus) would not be accessible.

Clarification: Initially when I checked the SMB Direct box (Under Windows Features On or Off), the computer reliably and always reported my full library of 12,000 tracks. Following BlackJack’s advise, unchecked the SMB-Direct box, and subsequently the computer no longer stably reported my full library. As mentioned above, eliminating the SLEEP feature on the XPS computer, once again, had the XPS computer stably and reliably reporting my full library.

Honestly, I don’t know what you expect. If you allow your XPS to go to sleep, then obviously the Nucleus will loose the connection to the parts of your library stored there, leaving you with only the local (to the Core) and Qoubuz tracks (approx. 1200). Additionally, if you allow the network adapter in the XPS to save power, you may loose the access even before “sleep time”.
If you want your XPS to save power/turn off when you’re not actively using it, then please copy your music library to the Nucleus (copy, so you still have the music on the XPS as a backup – unless you have already a better solution for that).

PS: Also think about adding an UPS to your Nucleus, especially if you put all your music on it. Eventually another one for the XPS in case you want to keep it always turned on as a server for your library.


Have a look at something like
This should allow you to automatically copy any new music files you add to you Dell XPS to the fileshare on the Nucleus.

Hi @Anne_Emerick,

Thank you for your patience in awaiting a staff response and we’re sorry to hear that you’ve been experiencing partial loss of your local library.

We’ve investigated diagnostics sent automatically to our servers from your Nucleus, and there’s no indication or file corruption as a result of the incident that caused it on your Dell several months ago.

That said, available logs indicate serious and recurring network failures affecting both playback and basic functions with Roon’s API. Some of these warnings in logging seem to occur after the technician would have made network changes.

Have you been experiencing dropouts with any of your Zones while playing music? In at least one instance in logs, local storage appears to fail due to network interruptions rather than the XPS being asleep (although that is the cause seemingly 99% of the time).

A few things to try:

I’d verify in the AT&T router that multicast is enabled and that no firewall settings on any of your Remotes are blocking activity for Roon or RAAT.

If you have the ability to adjust any settings in the two extenders, verify that multicast and IGMP snooping are enabled.

Additionally, the throughput booster that the technician installed very likely functions by allowing connected devices to “steal” bandwidth. In a mutli-device environment like Roon where a constellation of Remotes and Endpoints must communicate, this might not be so friendly. If you have the ability to test without this booster on, I’d recommend it. It might improve performance to a single Zone using a single Remote connected to the same access point, but it will wreak havoc on Roon in general.


Sleep cycles are an unfortunate but inherent limitation of local library storage on PCs, laptops, or other computers (as opposed to stand-alone storage drives, whether network or USB). Roon can’t access what it can’t see, and if the computer serving as a storage location isn’t responding to the network, these files will need to be available elsewhere.

Workarounds might work for your particular setup, but I would consider, if possible, adding local storage to the Nucleus via an internal drive or USB since this network can be shaky.

Please let us know if we can help further. Thank you!

Hello Connor,
It is EXCELLENT to hear from you.
Thank you SO MUCH for looking at my ROON Nucleus logs. I had no idea you had/have access to them–though glad that you do.
You totally corroborate that the root cause seems to be a network problem. I’ve been working with Dell, and they are quite sure it is not an XPS computer hardware problem.
When I have personal bandwidth, I will try turning off the network adapter booster, and assess how it affects access to my full library in various places in the house.
I will also contact ATT and ask for their help viz making changes on the new router (installed after the June 23 meltdown), and on the extenders. I have zero idea where the multicasting and IGMP settings are. Hopefully ATT will be helpful.
One community member (Blackdog) has suggested that since I have plenty of space on the Nucleus, that I locate my library there. I know, in theory, I could do that, but it seems to involve reformatting it (at the beginning), which makes me VERY nervous. Which means the instructions I’ve found on your site, are not very detailed. If I do go that route, I’m hoping you can help answer questions/remove ambiguity.
I’ll get back to you once I’ve done the adapter testing, and contacted ATT. Though overall, to me it is a total mystery WHY this problem has surfaced. Prior to the June meltdown, my ROON library was always stable and consistent. And at the time, I was using an older ATT modem. And the XPS computer was using sleep mode, regularly.
Note: I DO have a work-around, namely to leave the computer in NEVER sleep mode. I’m not happy about that (I understand this will cost me about $50/year), but at the moment, having access to my full library is very important.
Anyway, the ball is in my court.
Thanks so much for your suggestions.