Only plays on my PC

I’ve just installed Roon on my nearly new, MS Surface Studio. iTunes is also installed here and it found everything and seems to be working. However, it will only play the music through my itty-bitty Surface Studio speakers.

iTunes plays through my Sony STR-DN1080 receiver, so not sure why Roon does not. I’ve tried to set Roon up to see my Sony receiver but no matter what I do, I can’t play music through it. Chromecast is plugged into my Samsung LED television, it shows up on the Zones screen, but when I select it, nothing plays through it. Same with AppleTV, it looks like it is going to work, the AppleTV generates a 4 digit number that I enter into the Roon setup, but nothing ever happens after that. I can’t get over the feeling I’m missing something stupid, but frankly, its is getting very frustrating. When I want to play music anywhere else in my house, I have to go back to iTunes. What a hassle.

I’ve got gigabit Internet wireless service from Cox. All other devices working just fine.

Any help would be greatly appreciated.

Steve Larsen

One more thing, when I go to the “Configure Room OS” screen, I get an iconb wiggling around to show its working and the words “Search for devices…” but nothing ever comes up. The longest I waited was about 15-20 minutes before abandoning this step.

Hi @Steve_Larsen,

It looks like this receiver has Chromecast and Airplay functionality which should work with Roon. Do you see it in either of these sections when you go to Settings > Audio?

Do you receive any errors? Can you share a screenshot of the Signal Path when you are playing to this device?

Here is a screen shot of this never changing screen. I even download the mobile app, and it show the same thing:

And I did try the clear the cache and restart the app. Same thing, this screen never changes.
Thank you for replying and the helpful suggestions and questions. I do appreciate it.

Hi @Steve_Larsen,

This is only for configuring ROCK or Nucleus devices. Since you are using Windows as your Core machine, this isn’t necessary.

Can you share a screenshot of Settings > Audio?

Sure, it is below:

Still no sound on anything but my computer. Sad.



The STR_DN1080 is your Sony. And you have to Enable it before it can be used, and give it a name, like Sony AVR. Give that a try and see if it works.


Yes, I’ve clicked all over this section and nothing happens. I click “Enable” but it just momentarily turns a slightly different shade of blue, then goes back to the same color blue. I’ve tried clicking to the left side on the name first, then the right enable button, and nothing. I don’t get to the “give it a name” part. Thank you for trying to help me.


Maybe the two devices (STR-DN1080 and Google Cast Group) with the same IP-Address ( are the problem here?

1 Like

How do I eliminate the Google Cast Group? Or change its IP address? Isn’t there some way someone from Roon could do a shared screen session by phone and get this working? I’m pretty likely to be a $120 a year or $500 one time payment user if this gets working. But right now, I think something simple is hanging it up and I just can’t figure out what it is.


I don’t know where the Google Cast Group comes from. Have you checked the Google Home app?

Google Cast Groups are setup in the Google Home App and can be removed there as well. AS Blackjack, mentioned.

Hi @Steve_Larsen,

As suggested above, try removing the Google Cast Group in the Google Home app and try to enable it once more.

If you’re still having issues after that, please do the following:

  • Reboot your Core machine and the Sony receiver
  • Open Settings > Audio
  • Click Enable on the Sony
  • Make a note of the time you do so
  • Respond here with that time in your timezone

Once you’ve done this we can enable diagnostics so the team can take a closer look at why this is failing to enable for you.


OK, I turned off my iPhone. I unplugged the Chromecast dongle from my television, turned off the Sony reciever and rebooted my computer. I turned my computer back on at 7:24 AM and opened Roon at 7:25 AM, Phoenix, AZ time.

The only music is coming from the computer speakers. In Zones, two show up: MS Surface Studio (my PC) and the music shown there plays. The other thing showing in Zones is AppleTV Living Room, but nothing plays through it, although it shows little dancing bars playing, just no sound from the AppleTV in the Living Room. Here is a screen grab of the Audio setup screen.

And here is the screen grab from the Zones area:

Hi @Steve_Larsen,

Thanks for the timestamps, I’ve enabled diagnostics on your account. Once the diagnostics report is received on our end I’ll pass it along to the team for analysis. In the meantime, I was hoping you could try disabling the Google Cast Group from the Google Home app and let us know if there is any change after doing so.


Here is a screen shot from my phone. Looks from the phone like it is working, but still no sound.

If it helps your team, here is my network topography and devices.

1 Like

Hi @Steve_Larsen,

Just to verify, the Chromecast Ultra is doing the same exact thing as the Sony device and not enabling?

Can you try a factory reset via the Google Home app and re-configure Chromecast? Is there any change when doing so?