Open PDF on Android remote not working

I’ve read this thread:

but PDFs won’t open. The same as post 7 describes happens.
One Samsung Galaxy Tab4 (7") and a Note3 phone. When I download a PDF from the web it opens fine so a viewer is in place. Core on a linux box, 276 on all.
Remote on a win7 laptop opens PDFs as expected.

No one @support wants to look at this?
The Tab4 has Android 5.1.1, Note3 is 5.0

Hi @ogs ---- Thank you for the feedback here, we will take a look and see what we can come up with.

Your patience is appreciated.

Hello @Eric thanks for looking into this. This is definitively not high priority for me. In addition I’ll be travelling until mid January so I will not be able to follow up any questions related until I am back.

Hi @ogs ---- No problem myself and the rest the team are always glad to help. I know you are traveling currently so I don’t expect to hear from you until you return but I did want to provide you with an update.

I just got word back from our tech team that they have had a chance to try to reproduce this behavior you’ve reported. Their testing took place on a Nexus tables (Android 7.1.1) and a Nexus 6P (Android 8.1), and unfortunately were unable to reproduce the problem. However, in their test notes they mentioned that the PDF file(s) took approx. 20seconds to load on the test devices and in light of this are curious if you let the Roon sit for a bit longer does the PDF eventually open?


I have tried again after updating to 1.4. Still doesn’t work on my two Android devices. Remote on the Win7 laptop works as before.

concerning pdf opening on Android I’ve effectively noticed something strange on two different tablets with Android 5.1 for one of them and 7.1.1 with the second.
I’m able to open pdf files with Amazon Kindle application on both Android devices but if Kindle is not installed and only apps such as Adobe Reader or PDF Reader are installed, if I click on the PDF file I can’t open this pdf file and I don’t have the choice of the App to use to open this file as it the case for web browser such as Google Chrome when I try to open a PDF file in it.
If I install Kindle again I’m able to open pdf file with Android Roon remote app with Kindle.
It’s not a great problem for me as I’m using Kindle but I don’t know the reason why I can’t open pdf files with another pdf reader from Roon Remote.

Note that I’m using the latest build (294) of Roon 1.4.
I’m not 100% sure but this problem may have occurred since version 1.3 build 269 or 276.
I thought it was a problem with my own Android as it worked with Kindle but I get exactly the same problem with my new tablet (just received a few days ago).


Thanks @Le_Dom. The Kindle thing indicates that a PDF over the network does not have a normal association on some Android devices. Kindle expects network content and works with a PDF that is not local. @Eric if we could create this association PDFs would work even with Adobe Reader or one of the other readers IMHO

EDIT: flagging @support for this one Yes the Kindle trick works! Thanks once more @Le_Dom! I installed Kindle from Play Store on my Samsung SM-T235 with 5.1.1 and PDFs in the music folder open nicely. I do not mind having Kindle installed, but I’d prefer a proper fix to this issue so I can choose my PDF reader freely