OpenGL Error on startup

Installing the ROON software results in a message: “GL_ARB_framebuffer_object OpenGL extension is required. Your OpenGL drivers need an update or video card is not supported.”
I am using an Acer Aspire 1810T. What do I have to do?


Hi @pieterdvr, Roon requires OpenGL to run, so let’s make sure you have the latest drivers:

1. Visit the Intel download center at

2. Under “Intel Driver Update Utility”, click continue

3. Click “Check your system for updates”

4. Follow the instructions on screen as Intel automatically locates the latest driver for your machine, and install the new driver

I’ve got the same problem using the onboard ATI Radeon HD3000 with an AMD CPU.
I’ve installed the newest compatible ATI driver and still the error message appears.


same problem on my windows server 2012 r2… seems like its not related to OS but drivers for GPU???

Hi @Matty, can you open Device Manager in Windows, expand the Display Adapters field, then let me know what’s listed? Then we’ll go from there and try to get this sorted for you, thanks!

Hi @EAP, this is GPU related but we have OS requirements as well like I mentioned in your other thread, and we specifically don’t support server versions of Windows because they don’t ship with the audio and video components Roon requires. I hope you’ll bite the bullet and install the package I posted in your other thread! And if not, you should go ahead and install Roon on your personal computer and take advantage of your free trial, I think you’ll be hooked :wink:

My drivers are up to date.

Hi Kevin,

Do you have any further suggestions?

I have a friend who has a NUC running Win8.1 He was getting the same OpenGL error when he was using RDP to access his server. He did update the video driver from Intel (HD-4000), then hooked up the server and access locally (no RDP). Then Roon was able to be installed.

I was always trying to install via RDP on my 2012R2 server. I will try it later today without using RDP and see if I get the same error on my 2012r2 server.

Hi @pieterdvr, let’s get some logs from you. Because you can’t actually launch Roon we’re going to have to do it manually, though. Here’s how you can do it:

  1. Open Windows Explorer
  2. Click in the address area to the right of the text, to make it active like typing in a web browser, and type %localappdata%
  3. Find and open the Roon folder
  4. Right click on Logs, then Send To, then Compressed Zipped Folder
  5. Email me the zip file at

Thanks for the patience Pieter, I’ll keep an eye out for your email.

I had the same problem with Win8.1 Pro and remote desktop. I was able to solve the issue by using Real VNC to install Roon instead of the remote desktop. Once installed I am able to use Roon in remote mode from my mac to control my win 8.1 pro computer that is attached to my dac.

Well the problem is still the same even after i installed the other boring stuff like IIS (webserver) and lots of other CRAP (sorry microsoft) but the OpenGL is still there blocking me and for me the problem is really a windows server is a higher priority then roon because my High-End LSI RAID card can only work on Windows server OS. sure i can install a win7 or what ever to run Roon in my virtual environment but a install for JUST Roon would be a waste of CPU/RAM. and all i want to be able to do on that Virtual OS is to run Roon as a server not a Client. So for all i care a .bat file to get the server running would be great.

My Virtual 2012r2 only got one GPU and its called VMWare SVGA so its just a remote desktop driver or something like that… so i tried to force the server motherboard (supermicro) GPU into my virtual 2012r2 then i found out there is no driver…

About the free trail i need it to be tested both as a one computer server/client and a computer for server and 2 computers for clients and if everything will workout i will go for a lifetime subscription but so far its a NO-GO…

Hi @kevin,

thank you very much for your support.
meanwhile I was able to solve this problem by completely removing the drivers and reinstalling them.
Obiviously there are some problems with the ATI drivers, which cause inconsistent installations after updating them.

Btw - same same error message occurs, when trying to start Roon while using the Windows Remote Desktop …

It does not work on Remote Desktop (it comes available in windows 10).
Splashtop is a good alternative.

I am still waiting for a solution for the OpenGL Error. Do I have to buy a new computer? I have tried two laptops. Both give the same error. Is there a work arround?

Did you install the intel graphics package from acer? Or just checked whether the graphics driver installed by windows was up to date?

Looks like your laptop has a GL 2.1 GPU. I guess the question is what version Roon needs. If it needs higher then that would be a problem.
Looking at the error though GL_ARB_framebuffer_object already appears in 1.1.

Intel didn’t gave a newer driver to install when I asked for updates.

Any advice what to do next?