Operation really slowed by "adding music to library"

Hi there. I’m getting huge, five-minute (or longer) pauses between tracks, apparently whenever (because?) Roon keeps going automatically into “adding music to library” mode. I have the latest version (1.6), and plenty of memory. Is there any way to turn off the “adding music to library” function, which starts and then stays running? (The indicator keeps rolling and rolling, and it continually says “Adding music to library: of 179 tracks, 0 added, 0 identified” without changing.) Or perhaps I have too many albums in my library? But then I don’t know of any other way to keep track of my future listening, etc. Thanks for any suggestions.

Hi @Arved_Ashby,

I’d like to enable some diagnostics on your account so we can take a look at what you’re experiencing here. Before I do this, may I ask that you please do the following and make a note of the time you do each:

  • Reboot your Core machine.
  • Start up Roon and let the spinner go for ~5 minutes.
  • Reboot your Core machine once more.
  • Start up Roon and let the spinner go for another ~5 minutes.

This should allow the team to gain some insight into what you’re experiencing in the report. Once you’ve done this let me know the timestamps and I’ll enable diagnostics on your account. When the diagnostics report is uploaded I’ll send it over to our team for analysis.

Thanks for this. So by “core machine” you mean both my large music server (NAS) and my PS Audio DAC + renderer?

The core is what ever you are running Roon server software on.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.