OPPO UDP-205 USB issues

Until recently, I had been using Roon with a UDP-205 via ethernet. Since Oppo recently provided an update to do MQA via USB, I put Roon Bridge on a on a Raspberry Pi 3 with fresh dietpi install and connected it to the Oppo via USB. This setup works great for tracks with sampling rates > 192kHz, DSD, and Tidal MQA tracks sounding fantastic, and I’m able to confirm full MQA unfolding and rendering via this method. Awesome!

Here is the problem. Frequently, when changing from either to or from a Tidal MQA 352.8kHz track, I will get 0.5 sec of loud static/white noise sound (like potentially equipment damaging kind of loudness), then silence. Roon will continue to show it is playing the track, but when trying to go to another track, it will rapidly advance to each sequential track in a playlist along with silence. I can get the noise to happen about 50% of the time when switching back and forth from a Tidal MQA 352.8 and a song that is a non-MQA Flac or AAC. Interestingly, DSD files don’t seem to contribute to the problem. It will also happen with an album by Madilyn Paige where Roon doesn’t display file info at all.

I have no problem with Roon and any other connection, whether it is my Sony DAC/headphone amp connected to my MacBook Pro running the Roon Core, a DragonFly Red, Airplay devices, or DLNA.

I also tried a different linux distro on the Raspberry Pi 3 with the exact same response. I updated the Oppo, including the separate USB firmware updates, within the last week. I’ve confirmed the problem with multiple different AAC tracks from several different albums. I’ve searched the forums and internet without a solution. I have updated ffmpeg on the RaspBerry Pi.

Here are some Tidal tracks in MQA 352.8:
POLARITY (Hoff Ensemble)
TrondheimSolistene - in folk style
Mozart Violin Concertos (Marianne Thorsen and Trondheim Solistene)

Additionally, I plugged my MacBook Pro directly to the UDP-205 via USB and couldn’t get the problem to occur.

So in short, I’m having problems with RoonBridge on a Raspberry Pi 3 into an Oppo UDP-205 via USB switching to and from MQA 352.8. It also appears to happen with Tidal tracks that have poor filetype metadata.

If anybody has any ideas, I’d love to hear them.

Thank you,

Hello @Seth_Wallace,

Have you tried increasing the “Resync Delay” setting in the “Device Setup” for the UDP-205 zone?

I was able to find some references to loud noises occurring when using the USB input of the UDP-205 in this avsfourm thread. We have this unit in-house as a part of our Roon Ready program, I will schedule some testing with it in the next few days as well.


Thanks for your response. It didn’t seem to happen as often with 7000ms delay. It didn’t take long to replicate with 4000 ms delay.

I received the following response from Oppo customer service:


We have confirmed similar results when engaging MQA processing in the player when using the Asynchronous USB DAC. This is something that we are investigating and hope to address through a future upgrade to the player.

_Best Regards, _

_Customer Service _
_OPPO Digital, Inc. _
162 Constitution Dr.
Menlo Park, CA 94025

Hello @Seth_Wallace,

Thanks for the update. I apologize for the delay in getting back, we’ve been investigating this issue and finalizing our own feedback for OPPO.


I have RaspBerri Pi 3 with ropieee + oppo 205 and I have same problem.
If I try with my macmini with usb + oppo 205 it works very well.

Any news about it?
Thank you,


I haven’t heard anything new. Been running through RAAT rather than the raspberry pi while I’ve been waiting for some kind of fix.


Ok. Thank you.


Update: I’ve been working with Oppo customer support (excellent btw). Tried a beta USB DAC update which fixed the problem. High res MQA is working now without a problem. I’m super happy with the Oppo.

Is that available in public?

Not sure. They emailed it to me to test.

Can you please post screenshots of your set up for Roon with that beta. They sent me the same beta dac firmware yesterday and I still continue to have a drop outs with 0018 and the beta 0019 dac firmware and plan to roll back to 0015 tonight. I also continue to have issues trying to get any type of DSD 512 with the ultrarendu feeding the oppo from roon or hqplayer. Continue to get white noise and loud pops. I can do dsd 256 without a problem via roon or HQplayer…But my bigger problem with 0018 we’re drop outs with MQA any other file actually. I don’t have any dropouts with 0015 just no dsd 512. At least c 0015 i can have roon do the first mqa unfold…just wanted the full monty that 0018 promised. I would love for Roon oppo and sonore to have a teleconference and sort all this out!! :slight_smile:

Hi Seth!

I have exactly the same issue. Do you know how can I get the Beta version of the USB driver?

Should I just try sending an email to oppo asking for it?


Hi Seth,

I talked with oppo and they sent me the beta version 0119.

Unfortunately it did not solve my issue playing DSD files using Native mode. When I play DoP, it works fine.

I have RaspBerri Pi 3 b+ with ropieee + oppo 205 and I have same problem.

Could you please share the screenshot with your working setup?


Same issues presented themselves to me using a Pi3, Oppo UDP-205 and Ropieee once I updated the Oppo USB DAC to 0118.
Replacing the Pi3 with a Pi4 has solved things. MQA files either streamed from Tidal or from my networked NUC play with not a stutter with the Enhanced indicator. DSD is over PCM, native produces white noise.