Orbi RBK13: 504 Error, Single Router Setup

Roon Core Machine

Roon Nucleus +

Networking Gear & Setup Details

Netgear Orbi RBK13

Connected Audio Devices

ifi Zen Stream (wireless)

Number of Tracks in Library

About 10000 tracks

Description of Issue

Hello,

I cannot connect to Roon Arc and the same message shows up repeatedly. Please find attached the screenshots.

Thank you.

@Kwangdeok_Ahn, I see that the Orbi has correctly configured the port using UPnP. I wondered if the Orbi is connected to your ISPs modem / router or direct to the Internet connection. Could you confirm, and also share the name of the Internet Service provider. Thanks.

1 Like

Thank you for your reply.

I’m not quite sure if my Orbi is directly connected to the internet. It’s directly pugged in the lan port on the wall, but I put PPPOE ID/PW provided by ISP service person when initially setting up the router.

I’m currently staying in China, and using a local internet service(China Unicom).

Thanks for the additional information. I’m unable to help you–I’m a user just like you–but Roon support will come along soon to assist. Be patient, as there are many support requests at the moment.

Thanks :slight_smile: I’ll wait for a reply!

1 Like

Hi there @Kwangdeok_Ahn, and thank you for the tremendous demonstration of patience you’ve shown while we work through the queue of new ARC users who need assistance with port forwarding.

As a quick security note, I’ve obscured the screenshot you posted, as it contained some private information about your network we don’t wish to disclose on a public forum.

I’m noting two details about your network setup:

  1. In the fourth/fifth screenshots you’d shared for your Orbi Internet Basic or Advanced settings (doesn’t matter which), I suggest you select “Use Static IP Address” instead of “Get Dynamically from ISP.” While dynamic IPv4 won’t necessarily prevent port forwarding, we’ll try to confine as many variables as possible while we troubleshoot by setting a static IP.
  2. There is no router other than the Orbi in your setup, correct? There is a 504 error in your port forwarding diagnostics; that suggests a second layer of network address translation in your LAN might be preventing the Core from reaching the internet through the port. It’s likely this is coming from your ISP in the form of carrier-grade network address translation (CG-NAT) if it’s not from a second router. You might pass along the following questions to the customer support team at your ISP, to verify if they’re implementing some sort of CG-NAT or IPv6 that is blocking the port forward:
  • Have you implemented carrier-grade NAT for my account level?
  • Have you fully implemented IPv6, or do you have IPv4 addresses available?
  • Can I request a static IPv4 address to support port forwarding?
  • Are there any ports you have reserved at the ISP level I should be aware of?

We’ll keep a close eye out for your response. I hope you’re at least enjoying ARC on home Wi-Fi or with downloaded content offline in the meantime.

1 Like