Oreo startup freezes at the initial white-on-black "roon" screen


I have Pixel XL endpoint running latest stable AOSP-based Android 8.0 Oreo. Upon Roon Remote start on the phone, it shows the initial horizontal “roon” title screen, turns it to vertical, and freezes there.

Expected behaviour: App shows the “I acknowledge…” screen.

Actual behaviour: App stays forever in the initial “roon” title screen.

  • What version of Roon you are running: 1.3 build 274, on both Core and Remote
  • What operating system you are running: Core on Linux, Remote on Android 8.0 OPR3.170623.013

RoonServer_log.txt shows the phone connecting as expected:

11/19 11:26:14 Trace: [raat] RAATServer discovered: RaatServer Pixel XL @
11/19 11:26:14 Info: [raatserver] GOT SERVER censored::censored @ Pixel XL PROTOVER=1 RAATVER=1.1.21 
11/19 11:26:14 Trace: [raatserver] [RaatServer Pixel XL @] connecting (attempt 1)
11/19 11:26:14 Trace: [raatserver] [RaatServer Pixel XL @] connected
11/19 11:26:14 Trace: [rnet/RnetJsonClient] SENT {"request":"enumerate_devices","subscription_id":"0"}
11/19 11:26:14 Trace: [rnet/RnetJsonClient] GOT NONFINAL {"status": "Success", "devices": [{"device_id": "default", "name": "Default Output", "type": "android", "is_system_output": true, "auto_enable": true, "auto_name": "Pixel XL"}]}
11/19 11:26:14 Info: [raatserver] GOT DEVICE censored::default Type=android Name=Default Output 
11/19 11:26:16 Info: [brokerserver] Client connected:
11/19 11:26:16 Trace: [SOOD] Adding User IP
11/19 11:26:16 Trace: [raat] [sood] Refreshing device list
11/19 11:26:16 Trace: [raatserver] [sood] Refreshing device list
11/19 11:26:17 Trace: SENT NONFINAL DistributedBroker.ConnectResponse={ BrokerId=censored BrokerName='censored' }
11/19 11:26:17 Trace: SENT NONFINAL DistributedBroker.UpdatesChangedResponse={ IsSupported=True WasJustUpdated=False Status='UpToDate' HasChangeLog=False CurrentVersion={ MachineValue=100300274 DisplayValue='1.3 (build 274) stable' Branch='stable' } }

This phone with similar setup has worked fine before the latest Android.

All other endpoints work fine.

Things I’ve checked/tried:

  • Firewalls are not blocking anything and routing is fine. All systems are in same subnet.
  • App has all permissions it requests.
  • Clearing app cache/data or reinstalling the app does not fix the issue.
  • Rebooting phone does not fix the issue.
  • Android battery optimization settings change does not fix the issue.

If there is any additional information I can provide, please just let me know.

Thank you!

(Flagging @support)

Heh, I just noticed - I can play music to this Remote’s output just fine from desktop Roon Control. The Remote app just shows the white-on-black “roon” title screen, but plays the music.