OSMC Remote Controller not working

I am trying to use the OSMC Remote Controller without any success.

Logs from dmesg (the hardware seems to be recognised):

[    3.173229] usb 1-1.1.2: Manufacturer: OSMC Remote Controller
[    3.194749] input: OSMC Remote Controller  USB Keyboard Mouse as /devices/platform/soc/3f980000.usb/usb1/1-1/1-1.1/1-1.1.2/1-1.1.2:1.0/0003:2017:1688.0002/input/input1
[    3.274304] hid-generic 0003:2017:1688.0002: input,hidraw1: USB HID v1.10 Keyboard [OSMC Remote Controller  USB Keyboard Mouse] on usb-3f980000.usb-1.1.2/input0
[    3.298372] input: OSMC Remote Controller  USB Keyboard Mouse as /devices/platform/soc/3f980000.usb/usb1/1-1/1-1.1/1-1.1.2/1-1.1.2:1.1/0003:2017:1688.0003/input/input2
[    3.362605] hid-generic 0003:2017:1688.0003: input,hidraw2: USB HID v1.10 Mouse [OSMC Remote Controller  USB Keyboard Mouse] on usb-3f980000.usb-1.1.2/input1
[    3.662364] usb 1-1.1.1: new high-speed USB device number 6 using dwc_otg

Here is how the Ropieee config looks like:
https://drive.google.com/file/d/1jQoqDxNZ79TafPI4W0oFmt2-VH7o7MJW/view?usp=sharing

Here is the Zone in Roon:
https://drive.google.com/open?id=1bWKJNH5ebRzRfZvkvUHZT5llyGkZQ-F6

This is the remote I am using:
https://osmc.tv/store/product/osmc-remote-control/

Hope, someone can help. Thanks in advance

Can you send me feedback? Go the webpage, on the advanced tab there’s a button ‘send feedback’.

Thanks for the reply. I just send the feedback 1e402218c6985ab0.
BTW. The remote is working with my KODI an my PC setup. Thus, I am really sure there is something wrong with the PI running ropieee.

Just to be sure: you’ve enabled the extension in Roon?

No I did not.
But now I did. Still not working. I did reboot server and ropieee twice.
I just generated a new feedback fb894ecc41dac69a.
I am really helpful for your effort.

I did some experiments. I tuned of WIFI and used a wired connection instead. Suddenly it is working. I am pretty sure that I did not change anything else (but who knows).
So far so good. But esentially only Play/ Pause/ Next is working. No volume control, even though DSP volume control is working using the roon app. Is this normal?
Just another feedback fae051ac743fa6c1. From my side we can close the thread.
Thanks for your greate service. I am really enyoing RoPieee.

Volume control is indeed not implemented.
But one day … :wink:

1 Like

pssssttt @Bastian_Beggel,

Volume control will be in the next version. Don’t tell anyone.

5 Likes

Harry will that also include a volume slider on the display too? Even if its under settings it would be something :stuck_out_tongue:

@spockfish I’m facing an issue with an OSMC remote on Ropieee on one of my RPI setups. It does run with no issue on the other setups so the remote itself is working fine. The difference with the other ropieee setups is that this one does not have a display, only the usb remote dongle inserted. The OSMC dongle is recognized in Ropieee. I’ve sent a feedback e9521e9eafc7d86f. I’m at no clue why the remote does not trigger an action on this particular Ropieee setup.
Any help would be very much appreciated! Thanks in advance.

Ok, quick question: did you enable the RoPieee Remote Extension? This is a normal action when having a display, but it is also required for the OSMC.

Yes the Remote Extension is enabled, see screenshot:
RemoteExtension

I noticed in the Advanced tab I do not have the “Restart Roon Remote Extension” button compared to my other Ropieee setups.
image

that’s not an issue. can you send me feedback? So restart your unit, wait a few minutes, press a few buttons on the OSMC and then send me feedback.

Rebooted and pressed a couple of buttons for actions. Feedback is a00a1ea9f83c49ea.

Hi @Guy_Maurier,

AFAIK you running it with a grouped zone (Cuisine). It can’t find that zone, can you try with a normal zone?

Regards,

Hi @spockfish,
I tried it already thinking it could the issue but even as a single zone the OSMC remote does not trigger any actions.
On my other setups, having them grouped into a zone does not prevent from the OSMC to work, action is being applied to the entire group which would be expected.
I rebooted the unit as single zone, pressed a couple of buttons for actions and generated this feedback ba88913ec91cd840.

Weird. It complains about some configuration file not present, but I also don’t see an update on the zones part…

What are you running? ROCK? Can you restart your Roon Server?

I’m running the Roon server on a Synology NAS. I’ve restarted the server but no difference. Feedback 48e615b452e11bed .

I’m out of ideas here. You could try a different zone, but I assume you already have.
Next step is reflash I’m afraid.

@spockfish A reflash did the trick. One possible option is that the OSMC dongle might not have been inserted at time of installation of Ropieee.
Thanks for all your help!