OSX 10.11.5 and SMB; playing halts [OSX ISSUE] [Solved]

Yesterday I was having a hell of a time trying to play music off my NAS in Roon. Every 15-20 seconds the app would stop playing or skip to the next track saying files were loading too slowly. I figured I was just having wifi issues, but then i switched to an entirely hardwired setup and the same thing kept happening.

Could my NAS (a WDMyCloudEX2) just be too slow? Why would this be a problem only some days and not others? It’s not doing anything else but sitting there waiting for me. I checked fast.com and was getting 100Mbps on the same machine so it’s not a problem with any of the intermediate in-house switches.

I had just added a bunch of new (DSF) files to the library, but waited for the initial scanning to be completed before trying to play. I guess the background processing of the new files could have been interfering, but I didn’t see much network traffic between my NAS and the laptop.

How I can get useful diagnostic info next time this happens (I’m on Mac with AirportExtreme as router).


Restart Roon Server and/or Roonlink (if applicable). Do you use Smb for your nas connection, if yes, what Version? Try to analyse your Network chain If all Settings are always the same and dont readjust itself to other Settings, etc.

If this didn’t help, then give more Details of your configuration: What Hardware & System Version Runs your Server on, could you eventually move your Library to another Location to See if the Problems are the same, do you have a ac Airport or a n, etc.

Does it only happen with said dsf files or also with cd-quality flac files (they should be smaller). If this issue occurs on these files, too, I’d say it is something about the general network setup.
You could also test the speed of your NAS using blackmagic disk speed test.

I’ll check the NAS software version at home, but it’s a MyCloudEX2 so I’m not sure how to run blackmagic on it. Also, the wifi settings aren’t the concern because the same things happens when fully wired.

I’m not running a standalone RoonServer, just Roon on my laptop connected to the NAS via smb. How do I tell the smb version?

Sorry, i was quite unspecific about the Blackmagic Disk Speed test:
It is an Application you can run on your Mac. You can get it in the Mac AppStore.
When installed simply mount the shared folder of your MyCloudEX2 on your mac and select it as a target drive in blackmagic disk speed test.

1 Like

a few more: check if the mycloud firmware is current (latest from march 2016).
smb-version you can check in your dashboad under network services. you can alternate between smb1 and smb2 ( from the manual, maybe in later firmware more…).

check if your mac IS connected via smb. its best to connect manual in finder under cmd-k and then enter smb://IP_ofyourNAS, else you are connected via afp, which is not recommended.

if all this didn’t help then check the mac your roon runs on, if possible rebuild your Roon-Database (Backup your current Database). what is the endpoint connected to? Internal Speakers or USB DAC? if you use a alternate endpoint, does the problem persist? Always remeber to restart Roon after changing something. nearly all of my problems go away after i restart either roon server or roonlink software.


@Bernd_Hofmann thanks, a few answers:

  • will check firmware revision and smb version when i get home, but i have the MyCloud auto-update.
  • Mac is connected via smb://, I am certain of that.
  • I always quit the Roon app when I’m done with it, so always starting fresh when I want to play music.
  • connected to USB DAC (Dragonfly) this particular time, but I’ve noticed in the past that AirPlay does the same thing.

I’m on firmware 2.11.142, which i think is from April. SMB Max is set to SMB2. Not sure what any of the levels mean.

That said, I checked my NAS and lo and behold the twonky server, which I use from time to time with my NA8005 when I don’t have my laptop around to run Roon, was pegging the MyCloud’s CPU at 100%. I can only assume this was happening last night as well. That might explain things. Ugh. I haven’t tried since i shut down twonky, I will in a bit.


I had to rebuild my entire Roon database, it just sort of vanished from yesterday to today. Roon only thought I had 70 albums, instead of 250. That’s a little troubling. (The database is stored locally on my laptop). Roon is now stuck importing, pegging 100% of the laptop’s CPU to do basically nothing more.

Running disk speed test on a wired connection yielded 4.2MB/s writes and 5.2MB/s reads to my NAS. The app kept failing part way through saying there was an error reading the file. Every time. My NAS claims it’s healthy with no disk errors.


what mac do you have and what system-software are you running? I guess you running the latest Roon? Could you eventually Stop all unneeded software on your nas (twonky, etc.) and try again?

It looks that Roon sometimes didn’t see your entire data on the nas and then readjusts its database to what’s there. make sure you are on the latest systemsoftware on mac and firmware on your airport, i think in going over all this possible sources you may find the culprit.



Yup latest system software and Roon. Twonky stopped on the NAS.

Roon is now no longer reading or writing the NAS (0kb/s reads or writes to NAS) but laptop CPU is pegged at 100%. If I quit it and restart Roon on the laptop, it reads the NAS for a while, then gets stuck.

As far as Roon not seeing everything on the NAS, yesterday it saw 250 albums, today it saw 70. So it’s not like it missed things before, it missed a lot now.

Hmm, is it the same over wired and wlan? Restarting NAS may eventually Help. Try moving 50 or so albums from nas to local disk and let Roon rebuild its database, just to make sure that the network/nas are the source of the problems.

eventually try to play the same music not via roon, use any other musicplayer, vlc, vox or whatever. Are the problems the same or can you play without stuttering change tracks on the fly, etc.?

Roon is still trying to analyze the tracks (over an hour later), now it’s going slower and slower. The app itself is beachballing for 10-15 seconds when I activate it.

Hey @Mike_Pinkerton – why don’t we grab some logs from you and see if there are any clues.

If this is something with the network, or the NAS, or Twonky, we won’t know from the logs but if something is going on with Roon, the logs may give us more information.

Other than the new DSF files, anything else changed recently? How do you have the MyCloud setup in Roon? Mounted in the OS, or in Roon?

I’ll be in touch via PM about the logs. Stand by!

Sent logs, thanks for any assistance!

Wow, after letting Roon run all night, and then again this afternoon (with quitting Roon in between), it finally finished indexing! That was…unexpected.

Ok, I can still reproduce the problem. It looks like there’s a quick burst of network activity of 1-2MB/sec from my NAS and then Roon stops playing after 15-20 seconds. The files are 24/196 and are in the 300-400MB range.

A quick check of fast.com on the same laptop immediately afterwards yields 100Mb/s (12MB/sec), and although that’s going out to the external network, the internal network should be able to keep up.

While I was checking things, all my albums disappeared from Roon. I tried the Speed Check from the NAS and it gave errors. I tried a file copy in the Finder from NAS to local and it sat for 45 seconds before doing anything. Uh oh!

I rebooted the NAS and now Roon is re-scanning from scratch (60 albums so far, 300 to go!). If this takes another 24 hours, I don’t know what I’m going to do.

Are there other components in your network (switch, firewall, etc?)
4-5 MB does not seem very fast to me for a NAS. Are all of your components capable of gigabit connections?
Could you try to assign static IP addresses to your NAS and computer and connect the NAS directly to your ethernet port and check the speed again?

EDIT: Something else came to my mind:
First: Do you have a backup of your MyCloud files? I don’t want to be a pessimist, but it could also be a faulty disk in the MyCloud NAS. Maybe you have another computer and try to access this one over your current network and check if there will be errors too and if the speed is better as well…

My NAS is now in a state where I can navigate the file system, both in Finder and in Terminal, but copying any file either gives error -36 or “Device not configured”. File reads simply do nothing: either no data is ever transferred or it gets one chunk then stops cold.

These are files that I was successfully able to copy not 10 minutes ago; the files are fine. I swapped cables around, made sure everything was Cat5e, and even connected my laptop directly to the same gigabit switch as the NAS. Green lights on the NAS ethernet connection indicate gigabit. Still could never get more than 5-10MB/sec copying very large files. But now I can’t copy anything. Writes succeed, reads fail.

The NAS claims that all hard drives are fine and healthy. I disabled AFP entirely so that’s not running, nor is anything else accessing the NAS that I can tell. Rebooting the NAS this time didn’t help.

EDIT: That’s not entirely true, I can navigate files and play some files directly from Finder, and open smaller files. But copying files doesn’t work. I can use quickView to play entire .mp3 files but copying them fails.