OSX 10.11.5 and SMB; playing halts [OSX ISSUE] [Solved]

I just tried my 10.11.4 MacBookAir and i’m getting 25MB/sec from the NAS. The same files that fail on my MacBookPro (10.11.5) succeed quickly with zero issues on the Air.

Has anyone had problems with 10.11.5 and smb?

Rebooted my MacBookPro and while I’m getting half the copy speeds as the Air (10MB vs 20MB; laptops sitting physically next to each other, on the same wifi channel, 5GHz), I’m getting 2x what I was getting before, and files now copy as they should.


EDIT: And now it’s failing again after having Roon re-scanning my library. Could Roon somehow be screwing something up?


Appears 10.11.5 update is an issue for SMB. Can the thread subject be changed?


Can you test of you can connect via afp to it and check of file read/write errors will be gone then? The speed should also be higher then (according to mycloud benchmarks on orher websites).

Yeah AFP works fine on the same laptop, same OS version (10.11.5). However Roon won’t allow me to setup a NAS connection over AFP – it requires SMB.

So my previously working setup is totally broken and I can’t use Roon :frowning: Short of copying what I want to listen to the local disk before I start (which is a serious pain), are there any workarounds? I miss Roon already!!

The steps linked here


do work, and now my SMB throughput is back to normal. Yay!!!