Payback error using USB headset Hyperx Cloud Orbit S

Core Machine (Operating system/System info/Roon build number)

Linux 5.4.0-42-generic \ intel i7 9700, Samsung 970 EVO SSD \ Roon 1.7 build 610

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Mikrotik 962UiGS-5HacT2HnT 1gb local network, wired

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

HyperX Cloud Orbit S via USB

Description Of Issue

Roon skips all tracks if I select HyperX Cloud Orbit S as an audio zone or if I select the default audio device and select the HyperX Cloud Orbit S as default device in Windows 10 audio settings. I’ve tried Private zone on and off for this PC, tried Exclusive Mode, neither helps. If I select the speakers connected to this PC via 3.5mm jack - Roon is working fine. Roon works fine on other devices in my network as well.

Any idea how to make it work through my headphones?

Nvm, sorted it out. The problem was that the headphones were in 7.1 mode, so I had to set the stereo to 7.1 mapping in Roon settings.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.