PC as end device disappeared

Hi all,
I am an enthusiastic user of Roon and gladly confirm that the software is more than worth the money. Unfortunately, since a few weeks I have the problem that my PC is no longer displayed as a playback option within Roon and also cannot be re-integrated. This behavior did not occur after a Roon update installed shortly before, but out of the blue. All other devices can be selected within the network and I can play music through all of them. Using the Roon app on the PC, I can select all devices as well, with the exception of the PC itself. I have tried using the internal sound card (through which Roon playback has always been trouble-free) as well as two external sound cards, but the PC is completely invisible to Roon. Even when I try to select the PC as an end device via the Roon app from my iMac, it is not displayed. The same with the MacMini or any mobile device: the PC is simply not present for Roon. My music ist stored on a NAS and can be accessed through Roon by all other devices, except the PC. The PC on the other hand can also access the NAS without any problems and music on the NAS can still be played on the PC by other software. The Roon server is an Intel NUC. Can you help that I can use Roon on the PC again?
Kind regards

Which operating system and which Roon version is running where?

Hi Uwe,
It’s a homebuilt PC running Windows 11 Home 21H2 64bit, Roon version is 1.8 (build 933), music is stored on a NAS Synology DS218+, Intel Nuc with R.O.C.K. 1.8, build 933.

I just noticed something strange when I went to Roon to check the version number: in the info section of Roon, the PC is listed as “This device (PC)”, only in the audio selection it no longer appears. I added some screenshots to demonstrate what I mean.


Does the Windows 11 PC only show ALSA devices (sound card / HDMI0-4) from the Linux world?

Was once Linux stored under the same IP address in the router?

Make sure the roon exceptions in the firewall on the windows pc are still present, you might have had a windows update that has overwritten them. Although local roon treats them as network devices so tgey need to be seen.

No, as far as I know, there is no and never was a Linux device in this network. I had no idea that the ALSA devices referred to Linux. They are shown on every endpoint I use Roon with.

Then these are only the devices from the ROCK and Windows 11 does not find a passage as Ged describes it.

Hi Ged,

I’ll check when I get home for lunch and respond when I’ve had a look.


1 Like

Sorry guys, that didn’t work. I renewed firewall permissions for Roon, deleted the entry in the firewall section and did a re-install of Roon: still the same result - the computer is invisible to Roon. What else could I try?

The entry with IP address in the router could be deleted to connect then again in the other IP.

All Roon and RAAT entries under drive:\Users…\AppData\Local could still be deleted manually after the uninstallation before the new installation.

The computer name could be changed so that it is recognized as another/new computer with other audio devices.

The complete support form could be filled and wait with patience for a response from the team.

I tried everything but with no success. Then I read about the apparently new software “Roon Bridge” and thought that this could actually fit my problem exactly from the functionality. Out of sheer desperation I installed it, tried it out and voilà: my PC is again displayed as an audio device and now everything is working as it should.

Thanks for the constructive suggestions, nice to see that the community does not leave you out in the cold. Great!


1 Like

It’s nice to see that many not only find your solutions themselves, but also like to share them. Bridge has been around for a long time. It’s only for audio devices. Server can do more and Core can actually do everything, that’s the theory. In your case, however, only the bridge has uncovered the remote control. That’s surprising.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.