PC Audio Device Not Working Up After Upgrade to V1.7 Build 537

Core Machine (Operating system/System info/Roon build number)

Core on Synology NAS (DSM 6.2.2-24922 Update 6)
Roon Version 1.7 (Build 537) Stable

Remote on Windows 10 (Version 10.0.18363.778)
Roon Version 1.7 (Build 537) Stable

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

All devices on hard-wired ethernet. Router is Orbi RBR50 (Firmware V2.3.5.30).

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

No issue with my Devialet Expert, Beoplay, Macbook Pro etc. The problem only occurs with my PC speaker (Audioengine A5+) connected to my PC via USB with the Audioengine D1 DAC.

Description Of Issue

After I was prompted and upgraded to the latest Roon Build 537, playback on my PC started having issues – stopped after a few seconds of playback and in the end it was just playing each track for 1 second before skipping to the next track non-stop. After restarting Roon, my PC speaker (and all other devices connected to my PC) simply disappeared from the software. Tried re-installing Roon, restarting PC, restarting Roon Core and the NAS, restarting router, but PC devices simply doesn’t show up. Rest of the Roon system seemed to work okay…

Lastly, I am not sure if it is related, but when I click Setup => Configure Roon OS Devices, it basically get stuck at “searching for devices”.


Can you look to see if the firewall rules got reset on the w10 device. Temporarily disable the firewall and see if the devices show up.

Thanks. Disabled the firewall and didn’t make a difference. Also confirmed that both raatserver.exe and roon.exe are allowed in both public and private networks. FWIW, while I can’t play on my PC, I can use the Roon application on PC to control my other devices.

Ok. Will help proper support so they don’t have to ask that one :wink:

Don’t know if this applies, may be worth a try.

Thanks. Also tried removing and adding back to the exception list. All the devices connected to my PC still doesn’t show up.

Hey @dsd2roon – sorry for the trouble here.
So we can take a closer look, are you able to access your database and zip up the Logs folder for us?

If you can zip up that folder and send us a copy here, we can get a sense of what’s gone wrong here. We’ll walk you through the next steps after that so we can figure out what’s gone wrong.

Thanks in advance for your patience, and sorry again for the trouble here.

Sure. I’ve uploaded the database and logs. Please let me know if you need anything else.

I had a similar issue with my Roon not recognizing my Hugo 2 after the 536 build from the other day (in fact, Windows had trouble recognizing it).
What solved the issue for me was uninstalling the Hugo 2 drivers and reinstalling them (actually had to do it twice). I didn’t see anything in the forum about issues, so thought it may have been something else, but I think that it may have screwed something with the driver (I was switching devices in the Roon app).

Hello @dsd2roon, thanks for the logs! I took a look, and I’d like to have you refresh the RAATServer Folder for the PC.

You can generate a new RAATServer instance on your device by following these instructions, but please be aware that this will reset your Roon Settings -> Audio Tab to factory settings and I would advise making a backup of any custom DSP settings you have:

  • Create a Backup of your current Roon database

  • Exit out of Roon on the PC

  • Navigate to your PC’s Database Location

  • Find the folder that says “RAATServer”

  • Rename the “RAATServer” folder to “RAATServer_old”

  • Restart the Roon App to generate a new RAATServer folder

Hi, I’ve followed your instructions. But it wasn’t clear if you were referring to the RAATServer folder on my PC (just using the app has a remote) or my NAS (using as Core). So I did for both and also uploaded the logs inside both RAATServer folders in case you want to inspect them.

Doing it on my PC did nothing. However, doing it on my NAS (after I shut down the service, deleted folder and start the server), I was able to see my PC devices on my Windows Roon. However, after I restart my computer and start Roon again, the devices were gone again. I experimented a little and realized I could get them to show up again by just going into my NAS and stopping and starting the Roon Server – this is obviously not a long-term solution. For your further advice please. Thanks.

I tried a few more iterations and found that the devices will show up if I restart the Roon Server (core) on my NAS while the Windows App is opened. Subsequently closing and starting the Windows app will make the attached devices disappear again. Perhaps the “re-connecting to core” worked but not the initial connection somehow?

Hello @dsd2roon, I’d like to enable diagnostics on your account so we have more visibility on the issue. Could you repeat the steps you’ve outline to make this issue occur and reply to this thread with a timestamp of when you do this?


Now my Roon Win10 app is open and I can see my PC devices (first screenshot). At 13:21 GMT, I closed the Roon app and re-open it, my PC devices are gone (second screenshot). At 13:22 GMT, I stop the Roon server on my Synology NAS and start it. Almost immediately my PC devices all showed up in my Win10 app.

Hi, can I check if there has been an update on my issue? Thanks!

Hello @dsd2roon, thanks for your patience! I took a look at our internal ticket system for this issue and our team is still reviewing this information. Please stand by.

Hi. Thanks. The issue is still outstanding and when I open my Roon client on PC it still doesn’t detect my attached devices. I’ve tried changing to a different USB DAC and it doesn’t make any difference. As mentioned, either restarting the core on my NAS or turning on my phone’s Roon app (which add another “iPhone Device”) will magically cause the PC audio devices to show up.

Hello @dsd2roon, thanks for your patience! I brought this issue up to our team and they gave some recommendations to move forward with:

Can you temporarily try a different core? We wanted to know if this issue persists if you run Roon “all-in-one” on your Windows machine.

After reviewing the Roon logs you sent over with the team we were able to confirm that the issue should be noticeable in the RAATServer logs. I’d like to get that information over to our team for review. To get these logs, please:

  1. Exit out of Roon on the PC
  2. Navigate to your PC’s RAATServer folder (C:Users/youruser/AppData/local/RAATServer
  3. Create a zip file of the “logs” folder and upload it here.

Thanks! Let me know if you have any questions about these steps.

Thanks Nuwriy. Apologies for the delayed response.

I’ve uploaded Logs_Remote_Core.zip where in the logs you can see that the problem persists (i.e. unable to detect local audio devices like iFi DAC or Yeti, unless the core on NAS is restarted).

Then, I’ve switched to a new local core on my PC and the problem doesn’t seem to occur. The logs are also uploaded as Logs_Local_Core.zip.

I’ve recently purchase a lifetime Roon subscription and very much hope this issue can be resolved soon. Let me know if there is anything I can help. Thanks!

Hi, it’s been another two weeks and is there any update please? The problem still persists after upgrading both my core and remote to Version 1.7 (Build 555). Thanks!