PC Roon remote volume not updating after using Control + Up/Down then iOS device [Ticket In]

Hello. Hope all is good.
Volume position on PC does not update automatically. For example volume is set to 20 on PC. Then I change the volume to 22 using my iPhone. The volume is correctly set to 22 however the display on the PC is still at 20. And when I change the volume again using the PC by increasing by one step. It does not go to 23, it goes to 21 because the last volume the PC remembered is 20. So what actually happens is that the volume of the music decreases by 1 step going back to 21 after being set to 22 by my iPhone.
Is this a known problem? Do you know how I can resolve it?
Many thanks for your help @support

Is this issue on the Mac too?

Hello there. Any help on this matter on how to resolve this problem would be greatly appreciated. Best

Hi @skbe

Thanks for getting in touch and for your patience while we had a chance to reply, especially since your email reached us on a Saturday and we currently work Monday through Friday.

Can you share some screenshots of what you’re seeing on both of your devices? This should help us better understand this issue you’re experiencing.


Hi there

Thank you so much for reply

Not sure screenshots will help here as it is a behaviour that is better shown with a video. I made a video but couldn’t post it here. It can indeed very easily be reproducted by using a PC and a phone/tablet with the steps I described in my first post

Anyway here what happens:

I set the volume to 20 using my PC like that

Then I change the volume using my phone like that

So now volume is set to 23. It is in fact louder. However here the volume showed in my PC

Hi @dylan
Screenshots have been shared as requested. Is there any development here?
Can you please aknowledge if you or the DEV team have been able to reproduce the issue described above?
Many thanks

Hello @support
I received one response very quickly saying that it is the weekend some weeks ago but absolutely no update since requested screenshots have been shared

Hello @skbe ,

Apologies for the delay! Our team’s queue is longer than typical at the moment, but we’re working to get back to everyone as quickly as we can.

We are not seeing this issue on our end, updating the volume in the Roon app also updates it on the iOS remote.

In this screenshot, you are controlling your Powernode 2i zone, can you please confirm this issue impacts multipel zones or just the Powernode? Are you using the latest BluOS firmware on the device?

Hi @noris thank you for your response after all this time ! I thought I was clear: it is the contrary that does not work, updating the volume in iOS does not update it PC.

Try this increase the volume in IOS, then increase in PC, then increase in iOS. Look what each device displays as volume. You can also repeat the process in that order 2/3 times to make sure that the problem on your end as well

An to answer your question: it happens with all my devices (Roon ready, Sonos …) so I assume it is not related to a particular but to the PC app refusing to update itself for the volume display

Hi @skbe ,

I tried to reproduce this issue on my end on a Pulse 2i, a Chromecast Ultra, and the local iOS output and was not able to reproduce the behavior you describe.

I would take a look at the network setup, the volume mismatch might be due to one of your Roon remotes losing connection to the router, I see you are on WiFi in the screenshot, I would confirm if Ethernet also reproduces the issue.

Hi @noris

Ok. If you tried to change volume in iOS and PC several times in a row with using successively each device for each volume change and if then your PC ends up showing the right volume as your other devices then ok the problem comes from me.

Although I don’t understand why the problem can come from the Wifi: it works really correctly. And my iOS devices are on wifi and they show the right volume. Why iOS devices don’t have the problem while PCs connected to the same wifi do?

FYI I also tried with an Ethernet connection and it is the same problem.

How can I post a video to show you exactly what the problem is? And maybe to make sure you can reproduce it on the same manner?

What would be the next step to get my problem solved?

Your help is much appreciated

Hi @noris

I think I discovered a very interesting thing that you may consider when you try again with the test. Very strangely, when the volume on the PC is changed with the mouse, then the volume in the PC keeps being updated when the volume is changed elsewhere (in an iOS device for instance).

However I discovered that the problem that I described happens only when the volume on the PC is changed using the shortcut Ctrl+Up / Ctrl+Down. Changing the volume once with the shortcut makes the volume displayed on the PC not updated when it is changed elsewhere.

Please try this and tell me what you find.
Thanks so much for your help.

1 Like

Hi @skbe ,

Thanks for the additional details here, this was indeed the missing link :slight_smile:

I am able to reproduce some strange behavior on my end as well, so I’ll put in a ticket for QA to investigate this further. Thanks again for the report!

I believe this is now solved with the 831 build. Congrats!

1 Like

Thanks for letting us know that this one is resolved @skbe , glad to hear that the update has helped!

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.