PC works as remote but unable to play music locally

Core Machine (Operating system/System info/Roon build number)

Windows 10 64bit i3-7100 2.4ghz Roon 1.7 build 610

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Wifi 5 ghz 802.11ac

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Surfacepro 7 i5 with ifi idsd dac

Description Of Issue

I just bought a Surface pro 7 to use as a remote and connect a ifi idsd to. Roon works fine on the surface device and I can play music on all my other endpoints and core, but the surface pro does not show up as an option to enable in the audio settings. So what to do?

Can you provide a shot of your Setting - Audio - This PC ??

On the Surface Pro, in Roon’s settings check to make sure it’s not setup as a private zone.

That’s the problem:) there is no “this PC” in the audio settings. I can see all my other devices but not the surface?
Under audio I can see my Core, My other PC with dacs, and my receiver as an end point. nothing else?

Thanks! But:) Since I cant see my Surface in the audio section i can’t access the device and check if its set to private? or an I missing something here?

This could be a problem with Windows Firewall blocking, which we have seen before, and this is how we fixed. W10 - go to Settings, Firewall and Network Protection, Firewall notification settings, manage notifications. Firewall and Network Protection Notifications, Notify me when windows blocks, set to on, and tick the 3 boxes below. Ideally reboot, and load Roon control app. At some point W10 will ask you if you want to allow through Firewall, any you answer yes to all. The device should now be able to be added in settings/audio. (It may not ask for Firewall permission until this point). Hope this works for you.


Yes!!! That did the trick!!! Thank you so much. Good and clear instructions! Thank you again. This was driving me crazy:)

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.