Performance issues

Roon Server Machine

Windows 11 Pro, HP gaming PC w/ i5-11400 @ 2.60GHz and 32gb RAM
Roon v. 2.0 build 1359
Roon for iPhone v. 2.0 build 1357

Networking Gear & Setup Details

AT&T fiber router in passthrough mode, Deco X55 mesh WiFi, Roon server connected via ethernet, no VPN, local tracks served from QNAP NAS, streaming from Qobuz

Connected Audio Devices

Rose HiFi 250 in main listening room fed via ethernet, Denafrips Pontus DAC via USB
Grace m920 in office

Number of Tracks in Library

local tracks ~2,000

Description of Issue

For the past couple of weeks, I’ve been having a lot of issues with performance of Roon. It often takes 30-60 seconds just to change screens, change tracks, etc. Even just advancing from one track to the next on the same album often incurs this delay. This behavior is the same on the server and on a laptop and an iPhone running the client. It doesn’t matter what the source of the tracks is – problem is the same for both local tracks and streamed tracks. Sometimes restarting Roon helps, sometimes it doesn’t. When it does, I often have to do it multiple times in a listening session.

The iPhone app has also gotten pretty unstable, often crashing.

1 Like

I see similar problems have been reported by multiple users under different terminology.

Really? Four days later and no response of any kind from anyone at Roon?

Roon’s Support team is just four people and they operate a queue system (they also don’t work weekends). Your issue will have been added to their queue automatically and they will respond once it reaches the head of their queue.

1 Like

Trent, reboot Windows and Roon and it might go faster

Hi @Trent

Just a fellow Roon user.

Reading your post this does it with local, Qobuz and regardless of Server.

I don’t want to point at your network, but have you made any alterations to your network.

A reboot of your network is a starting point I think should be explored.

Is your Roon Server connected to the Primary Deco unit, the one connected to the ISP box?

Are the other Deco units wired for backhaul or just using WiFi?

Is you NAS connected to the same Deco unit as the Roon Server?

Four people? Wow. Roon needs to improve on that.

2 Likes

No network alterations in a while, and it hasn’t been long since it rebooted. The server was also rebooted.

Roon Server has an ethernet connection to a switch connected to the Deco primary. The other units are just using WiFi. The NAS is connected to the same switch as the Roon Server.

I’d be ruling out your network based on this. It’s as I would recommend to eliminate issues.

The switch I guess is an unmanaged type.

Let’s give @support a nudge. As it’s a Friday you may not get a response until Monday at the earliest. Support is a team of 4 good guys.

In the meantime, just streaming from Qobuz, disconnect your NAS. I’m just trying to see if something is causing this while you wait for Roon to look at your servers diagnostic data.

Also try a different ethernet cable between your Roon server and the switch. Then NAS and switch.

Do one thing at a time to see if anything helps.

The new version seems to have made things a lot better. Will keep an eye on it for a few days, but at first blush, at least, it seems like a big improvement.

Well, now it has gotten incredibly slow again. Yesterday and the preceding days it was fine. Today it’s like molasses. Nothing was changed, restarted, or rebooted.

Hi @Trent,

Thanks for sharing your update, and I’m sorry to hear the drop in performance has returned. We have a possible fix for you that currently lives over on our early access build - we’re hoping to get a full release out this week.

I was able to review a recent diagnostic report from your Roon Server, and did see a handful of poor connection traces during playback, for example:

Warn: FTMSI-B-OE qo/DB8AFD7D: poor connection kbps:6316.0 (min:7996.0)

It seems to dip just below the threshold needed for a steady connection. I’m curious if you might be able to review your router settings, and see if you have the option to temporarily set your Roon Server to receive network priority when in use?

Thanks for the response. I’ve made it a high priority device. Will see if it makes a difference.

1 Like

Things seem to be better, so far. There was also an update that installed sometime midweek, I think. Don’t know how much that mattered.

1 Like

Well, I jinxed it. Slowness again. This was using the server itself. I didn’t try remote.

Somebody jumped the gun by marking this resolved.

Removed the Solution label.

@support should see this again in their queue.

1 Like

Hey @Trent,

Thanks for the update! Sorry to hear your performance issues have resurfaced.

To confirm, when using Roon strictly on the windows 11 running Roon Server, you didn’t experience any issues? Which remote did you experience the dip in performance on?

In the meantime, it’s likely the performance issues you’re experiencing are linked to Qobuz. Lets see if clearing your Qobuz cache alleviates your issues:

  • Create a fresh backup of your current database
  • Find and open your Roon database
  • Navigate to Roon/Cache
  • Move the contents of the /Cache folder elsewhere, like your desktop
  • Try restarting Roon and verify if the issue still occurs

Our team is taking a closer look into the performance issues you’re experiencing, I hope to have more information to share soon :+1:

To confirm, when using Roon strictly on the windows 11 running Roon Server, you didn’t experience any issues? Which remote did you experience the dip in performance on?

The opposite. Slowness on the server. I didn’t try any of my remotes.

Will try the cache clearing, later.

Clearing the cache doesn’t seem to have helped.

And tonight it has gotten quite noticeably worse again.