Perofmance Issue on intel NUC

Core Machine (Operating system/System info/Roon build number)

Centos 8

*-memory description: System Memory physical id: 35 slot: System board or motherboard size: 24GiB

*-cpu description: CPU product: Intel® Core™ i3-7100U CPU @ 2.40GHz vendor: Intel Corp. vendor_id: GenuineIntel physical id: 3c bus info: cpu@0 version: Intel® Core™ i3-7100U CPU @ 2.40GHz serial: To Be Filled By O.E.M. slot: U3E1 size: 1275MHz capacity: 2400MHz width: 64 bits clock: 100MHz Regards

Roon 1.7 (Build 528)

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

1Gb Ethernet

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Usb Interface on Remote Streaming

Description Of Issue

I’ve got major hickups and setbacks mostly while playing high res audio. Although I got an Intel NUC running with an External Raid including an large Swap space on SSD. If I start playpack I get over 100% CPU load

Hi @Yannick_Langer,

Welcome to the forum! How large is your Roon collection? What is the number of tracks/albums in Roon Settings -> Overview?

1 Like

Thank you for thinking of me :wink:

Hi @Yannick_Langer,

Thanks for the link to the other thread. Since your Roon Server is installed in Docker, we cannot properly support this. While it may work, we do not perform any testing of Roon in Docker/VMs so troubleshooting this issue from our end is difficult.

My suggestion would be to use the native operating system to host the Roon Core. It does use a fair amount of resources when you first scan the library, but after the library is imported with the associated metadata, Roon should use less resources.

Hi Noris,

I just did a complete fresh install :sweat_smile: of my server. Now I get the same error. (Using Linux Native installation)

-> Process 5980 (RoonAppliance) of user 0 dumped core. Stack trace of thread 5784: #0 0x00007f7a8f990fff n/a (/lib/x86_64-linux-gnu/ #1 0x00000000005ca974 n/a (/app/RoonServer/RoonMono/bin/mono-sgen) #2 0x00007f7a8ff250e0 n/a (/lib/x86_64-linux-gnu/

I just cant authenticate - thats the output:

terminate called after throwing an instance of ‘OpenHome::NetworkError’

at <0xffffffff>
at (wrapper managed-to-native) OpenHome.Net.ControlPoint.CpDeviceListUpnpServiceType.CpDeviceListCreateUpnpServiceType (intptr,intptr,uint,OpenHome.Net.ControlPoint.CpDeviceList/CallbackDevice,intptr,OpenHome.Net.ControlPoint.CpDeviceList/CallbackDevice,intptr) [0x00030] in <21295a8acb1a4b59920209b723ef0864>:0
at OpenHome.Net.ControlPoint.CpDeviceListUpnpServiceType…ctor (string,string,uint,OpenHome.Net.ControlPoint.CpDeviceList/ChangeHandler,OpenHome.Net.ControlPoint.CpDeviceList/ChangeHandler) [0x00042] in <21295a8acb1a4b59920209b723ef0864>:0
at OpenHome.Net.ControlPoint.CpUpnpDeviceListFactory.CreateListServiceType (string,string,uint,OpenHome.Net.ControlPoint.CpDeviceList/ChangeHandler,OpenHome.Net.ControlPoint.CpDeviceList/ChangeHandler) [0x00007] in <21295a8acb1a4b59920209b723ef0864>:0
at Sooloos.Broker.Transport.SongcastDirect.ReInit () [0x00235] in :0
at Sooloos.Broker.Transport.SongcastDirect…ctor (Sooloos.Broker.State,Sooloos.Broker.Transport.Module) [0x0007e] in :0
at Sooloos.Broker.Transport.Module.Enable () [0x001e9] in :0
at Sooloos.Broker.Transport.Module.UpdateEnabled () [0x00035] in :0
at Sooloos.Broker.Transport.Module.b__74_0 (Sooloos.Broker.Api.LoadStatus) [0x00001] in :0
at Sooloos.Broker.LoadStatus.b__35_0 (System.Action1<Sooloos.Broker.Api.LoadStatus>) [0x00002] in <b547e688cd0442d6941264aab090c074>:0 at Sooloos.Concurrency.EventHandler1<HANDLER_REF>.Dispatch (object) [0x0000c] in <001a5c08c540499997250d588daba7cb>:0
at Sooloos.Concurrency.EventHandlers.Dispatch (System.Collections.Generic.List1<Sooloos.Concurrency.FiredEvent>) [0x0003b] in <001a5c08c540499997250d588daba7cb>:0 at Sooloos.Concurrency.SharedState1<THREAD_REF>.FlushEvents () [0x00034] in <001a5c08c540499997250d588daba7cb>:0
at Sooloos.Broker.State/<>c.<_InitTransportThreadSync>b__149_0 () [0x0001f] in :0
at Sooloos.SynchronizationContextThread.OnBeforeEntry () [0x0000b] in :0
at Sooloos.SynchronizationContextThread.Dispatch (Sooloos.SynchronizationContextThread/SendOrPostWrapper&) [0x00007] in :0
at Sooloos.SynchronizationContextThread.Go () [0x00025] in :0
at System.Threading.ThreadHelper.ThreadStart_Context (object) [0x0001f] in <370a0c27f4b74d1a81431037df6d75bf>:0
at System.Threading.ExecutionContext.RunInternal (System.Threading.ExecutionContext,System.Threading.ContextCallback,object,bool) [0x00073] in <370a0c27f4b74d1a81431037df6d75bf>:0
at System.Threading.ExecutionContext.Run (System.Threading.ExecutionContext,System.Threading.ContextCallback,object,bool) [0x00004] in <370a0c27f4b74d1a81431037df6d75bf>:0
at System.Threading.ExecutionContext.Run (System.Threading.ExecutionContext,System.Threading.ContextCallback,object) [0x0002f] in <370a0c27f4b74d1a81431037df6d75bf>:0
at System.Threading.ThreadHelper.ThreadStart () [0x00014] in <370a0c27f4b74d1a81431037df6d75bf>:0
at (wrapper runtime-invoke) object.runtime_invoke_void__this
(object,intptr,intptr,intptr) [0x0004f] in <370a0c27f4b74d1a81431037df6d75bf>:0

I hope it helps…

Hi @Yannick_Langer,

Are you by any chance running Plex / Emby on a PC on this network?

Thank you four your help and for the advise. Now everything seems to work. I already disabled 1900/udp on my plex server but this didn’t help. Then I realized, that the port is still open inside the docker-compose file. Changed this and it worked.

Now I tried to use ROON inside Docker and it worked to. So everything is fine and I can enjoy your great piece of software. :slight_smile:

Regards, stay safe:-)!

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.