Persistent ROCK Failure after update

Roon Core Machine

  • NUC10i7FNH1
  • HyperX Kingston 8GB 2666MHz DDR4 Non-ECC CL15 SODIMM
  • Samsung 970 EVO Plus 250GB NVMe M.2

Networking Gear & Setup Details

All items are ethernet wired. Wi-fi is only for Roon Remotes. Not currently using a VPN.

  • Fibre Optik modem (Nokia G-240G-A Optical Network Terminal) connects directly to the next item.
  • TELUS WiFi Hub Router (Arcadyan?, ISP supplied)
  • ASUS GX-D1081 Network Switch
  • TLink TL-SG1008D Network Switch

Connected Audio Devices

All items are Ethernet connected unless otherwise specified:

  • Simaudio Moon 280D DAC w/MiND renderer
  • Synology NAS DS213 3TB X 2 WD Red
  • WD Mypassport USB hard drive, connected to NAS only as a backup

Number of Tracks in Library

66,650 tracks

Description of Issue

I am constantly having a series of failures usually culminating with the “DATABASE FAILED TO LOAD. Restore a backup?” message. I have reinstalled ROCK. I have rebooted, restored, and rebuilt databases and added the new versions of codecs. I’ve moved the RAM to the other slot. I’ve checked the nuc which seems to be fine. I have seen a few other messages, as shown below. This and other problems are consistent with many of the Roon updates. This started this past week with the latest update. Usually, I can get past the issues after a day of screwing about with things via the PC. But this time I can’t seem to get anywhere it’s a vicious cycle of failures and I am lost as to where I can turn.

Always the RED light, Connecting…

Then… Oh, Good!!..oh… (I realize the build numbers are different. It doesn’t mean I do not see the same screen, more or less. I just grabbed the wrong screenshot.)

image

Such a long wait… Usually forever.

Then, if by some miracle ROCK is seen and finally loads, I get a very brief “Oh oh. Something’s wrong here…” error message and back to the beginning.

I don’t-know what is going on, but if you get this often after updates, something is fundamentally wrong. I and most users never get any of this. What is it that you do when you “screw about” for a day???

Are you able to get to the Rock WebUI, in your internet browser of choice, using the IP address?

Yes, No problem getting the Web UI

Go over the ROON troubleshooting steps. Restore and wait, all that screwing about.

I don’t know what you mean

Constant failures, especially around update time, sounds like your boot SSD is failing. Try a new one.
Or the NUC board itself has issues. I don’t think these can be easily repaired, so new NUC time.

After replacing hardware, start with a fresh DB (no restore) to confirm that the system is stable, before trying a restore.

This was suggested last time you asked 3 months ago. Did you ever try a new SSD?

1 Like

No, I didn’t go out and buy a new SSD just to see if the current one has issues. I fail to see how when doing an update would cause a relatively new SSD to fail instantly. During the rest of the time of Roon’s functioning, I too have no problems. I previously tried this nuc as a PC as well just to see its functions. I have tried other diagnostic tools suggested by tech friends without indication of failures. The only action I did that actually made any difference was to move the Ram card to the other slot. Friends said it could just have been a poor connection at that time.

I still think the addition of diagnostic tools by Roon would be appropriate.

I did blow the whole core out with a fresh installation and a brand-new rebuilt database. I also started a new backup location folder. No more backup restores, as that action achieved nothing.

Hi @Roderick_Miller1 ,

Have you been able to login back to the ROCK on a fresh database? If you are able to log in and let the unit run, we can activate diagnostics mode for it and check to see if the ROCK system log has any errors associated with the SSD. Please, do let us know if you are able to get the unit up and running again.

1 Like

I have tried 2 different SSD’s, both with fresh ROCK installs. Newly built database, and I am awaiting a new SODIMM module. So far I have had no success. If the memory module fails, then it may be the NUC itself. It sucks not to be able to use the service I have paid for but I understand the troubleshooting process and am taking it as it comes.

1 Like

I bought a new SODIMM 8Gb module and reinstalled ROCK. So far, working fine. I’ll reserve judgement for a few days to see if anything happens. But at least so far, it appears to have been a RAM issue. This is odd because Windows ran fine on the same setup, which I would presume to be more of a mem hog than ROCK might be…

2 Likes

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.