Persistent Roon Airplay Stuttering in otherwise stable setup

Apologies for the duplication of post - I originally posted the below on the “Airplay Stuttering” thread, but am keen to resolve before my trial runs out and the information on the other threads has not helped.

I currently get hiccups, stutters and the occasional burst of digital noise every 20-30 seconds through Roon, but exactly the same setup runs flawlessly via iTunes outputting to the AE (via CoreAudio I assume?)

I am running:

Source: late 2013 Retina Macbook Pro 13", 8Gb, i5, 512Gb SSD, Sierra OS, iTunes library with mostly ALAC lossless or HD
Streaming via Older G2(?) power brick style Airport express connected via TOSLINK to
Cambridge Audio DACMagic Plus hooked to amp and speakers.
Router is a FrizBox 7940 and working well for other devices in the household.
The only thing connected to the AE is my MacBook - it is only used as an Airplay device and not an access point or extender

  1. I have turned off the background and “on the fly” analysis for Roon
  2. I have disabled my Little Snitch network filter and other background services
  3. In Activity monitor I can see Roon is taking between 10-25% CPU whilst playing and is generally the highest consumer of CPU cycles with my MacBook otherwise “at rest”
  4. Plenty of free RAM!
  5. I have closed other running apps - iTunes, Mail, Safari etc…
  6. If I plug directly into the DacMagic via USB or into one of my portable DACs and headphones, all works fine

None of the above has solved the issue - anyone else got any ideas?

Hi @Iain ---- Thank you for the report and my apologies for the troubles here. May I kindly ask you to please verify / provide the following:

  1. A screenshot of your audio settings for this zone in Roon.

  2. A screenshot of your signal path coming out of Roon when streaming to this endpoint.

  3. Can you confirm if you are noticing this behavior with ANY other endpoints in your setup?

  4. Does the codec or sample/bit rate contribute to this behavior at all?


Hi Eric,

  1. Screenshots below.
  2. I haven’t had any other issues that I am aware of with connectivity or streaming on other devices nor when using the AE and everything behaves fine when you take the AE out of the equation and use USB to either the DACMagic or one of my other portable DACs
  3. I have tested ALAC, AIFF and lossy 320kb MP3 files…all display the same behaviour. I haven’t tested enough to see whether file size/type has any impact on frequency or severity of the issue!

I am now just going to kick off the background analysis worker again and leave it just to see if anything changes once my entire library has been analysed/completed…looks like it may take a while!

I had a number of issues with the Older Airport Express (the one that looks like a MacBook power block). Finally gave up and replaced it with a RPi. You might not win this one sadly.

Conveniently I do have an RPi but never really found an Audio distro I liked better than iTunes and the AE!

What are you using on the RPi that works well with Roon? I guess it does have the advantage of being bit perfect and capable of streaming my HD stuff without downsampling.

Ok - so I got my Roonbridge working - testing now…

Given that it is bit perfect unlike my AE, might be the way to go regardless of getting the AE working!

So now I am having similar issues with the Roonbridge (RPi 3)


With hi res tracks, it works fine for half a track, then I get the “An audio file is loading slowly.” message and the track either stops playing or skips to the next track, stutters a bit then either recovers or stops.

This happens with my Roonbridge connected to my home network either via ethernet through a D-Link DGS-108 Dumb switch which is connected to my router OR via WiFi only.

I am trying now with the Roonbridge plugged directly into the router.

As above, source is the MacBook connected via Gigabit WiFi.

Right! So if I take the switch out of the equation it seems (so far) to work Ok.

Unfortunately, as good as Roon is, this is all starting to become rather hard work and I am spending my time messing around with tech, rather than actually listening to the music- which pretty much undermines the whole point of Roon in the first place!

I am not looking to run more cables, replace other hardware or upgrade my source when my iTunes + AE setup “just works” (not as common for Apple stuff these days as it used to be!) so currently a subscription is not looking likely, which is a shame.

Another update for anyone still watching:

I went back and checked all my settings again - I changed the buffer size back the default (I don’t recall setting it to 500ms, but must have done at some point in all my tweaking…) of 100ms and have tested the streaming with one of my biggest HD audio tracks (Yes - Close to the Edge at a hair under 400Mb) and this time it worked flawlessly!

Not sure if this was fluke or specifically down to the buffer settings, but will continue to listen and test.

Once you get past the initial fiddling, the pi should be pretty maintenance-free. I shifted to the Dietpi install, which packaged up Roon bridge in their install. Took about an hour to get it all sorted and now I can pretend they don’t exist. I leave them on all the time and they just work.

I think a willingness to tinker is directly related to the amount of money you want to spend. There are out of the box options that are Roon ready, but they cost more than the pi. There is a list of partners here:

Glad it seems to be working for you now. The power of Roon is in the interface. I think you’ll find once you begin to browse that it’s vastly superior to the iTunes experience (which is where I was coming from as well).

Thanks for the thoughts and for directing me down the RPi route.

I listened all last night and it coped with everything I could throw at it so I think I have cracked it! It is certainly a better option than the AE as far as accuracy is concerned, so I will stick with it and build around that.