pfSense and accessing Roon Core from remote location?

I have read that it’s possible to configure a local VPN server and connect to your Core from outside your network.

I’m running pfSense as a gateway router on my LAN and have configured a VPN server for accessing my LAN devices. However, I’m not able to connect to my Roon core as the server I have set is based on tun protocol and not tap plus it seems that the server provides IPs from a different subnet to the connected devices from outside.

My question is, has anyone configured a VPN server on pfSense and if yes, would you care to share the configuration? :slight_smile:

Many thanks!

Traditional VPNs do not work, unless you have the VPN terminate directly on the Roon Server. You cannot terminate the VPN on your pfSense device and have Roon work over it (since you won’t get any multicast forwarding).

SD-LAN solutions like ZeroTier work, but are officially unsupported. There are many discussions about ZeroTier already in the forums here, for your searching pleasure.

1 Like

Thanks for the valuable info. I will do a research on ZeroTier as you suggest.

Hello again.

I have set a Zerotier network and can ping my devices with the ip’s provided by the Zerotier network.

Question is where do we go from here now?

When I run the Roon app on my remote WIN laptop it searches for the Core but no success…

Am I missing something with this? Is there any other setting I have to apply on y remote computer after configuring the Zerotier network?

It should “just work” so long as the devices are in the same ZeroTier network. Nothing special to enable multicast, which is how Roon finds things. Did you restart the RoonCore after you joined the ZeroTier network on the Core system? It might only enumerate the interface list on startup.

On the Windows system, install Wireshark and see if you see traffic from Roon on the ZeroTier interface.

1 Like

Thanks for the prompt response!

Yes, I restarted the server several times and have set the Zerotier application to run with startup.

From my Zerotier account I have authorised all 3 devices (server, Win Laptop and mobile phone) and I have assigned them with IPs

I can ping my server or my phone from my Laptop right now despite I’m on a remote LAN.

I was hoping I was missing a setting like bridging network adapters but as long as you say it should work out of the box, I’m 100% sure I’m doing it right! No response from the core though…

I will install Wireshark as you suggest and see if there’s any traffic.

Unfortunately, I can’t get this to work no matter what.
I have now installed roon on my Linux instance of my laptop (dual boot) and experience the exact same result - searches for the Core indefinitely.

Unless there is a special network configuration I have to do within the server computer or possibly a port related to this operation on my local network ?), I have tried all possible solutions and have run out of ideas

To answer my own question and for future reference, I have finally got it working.

The problem was with Windows Firewall of the Server computer. I had to disable the firewall rule for the specific Zerotier virtual network and now I can reach my core from outside my LAN.

Ah, makes sense. Glad you got it working.

1 Like

Yes, I have managed to connect to the server but unfortunately connection is intermittent and thus not usable.

A shame as I had been super-excited with the prospect of using Roon remotely…
It seems my 100 / 9 mbps connection is not up to the task.

Thanks anyway for the great help.