Pi 3s with Ropieee hang regularly

I run three Ropieee Pis at this time. One is a Pi 4 and it works fine - never any trouble at all. The other two are Pi 3s (B+ I think, both of them). For some reason, these Pi 3 installations never last more than a few days before hanging - they are complete unresponsive then, I can’t use them from Roon or bring up the web interface even though I know the IPs.

It could be a coincidence that the two problematic Pis are version 3. One other difference is that the Pi 4 uses a DAC via USB, while both the Pi 3s have HATs.

In any case I’m wondering if there’s any way of diagnosing issues like this? I understand there used to be SSH access in the past, but now it’s not available. Any other way of getting to system logs?

I may try to replace the two Pi 3s with 4s - just thought I’d ask first to see whether there was anything that could be learned before I do this.

Send @spockfish a feedback from the Advanced tab, at the bottom, and post here the feedback id

Okay… I don’t like that at all, sending logs without a chance to inspect them first. I did it anyway, and here’s the id: 9186f39f0203d62e

This particular device was hanging a few days ago (not for the first time) and I pulled the power plug on it after I noticed what was going on. Just now I plugged it back in, waited for it to start up and then sent the feedback right away.

Final thought: I have updated the software on both these devices more than once, while the problem persisted.

Thanks for your help, @Stefano_Antonelli

The logs seem perfectly fine actually.

Only thing is that you’re not on the latest release. Not that that would make a huge difference (I suspect), but still I would advise to upgrade.


Yes - as I said, this device had been sitting for a few days since it last hung. I wanted to send the logs immediately, but I have now run the update.

So… perfectly fine. That’s good to know, but then how do I debug why this device consistently hangs after a few days?

When it hangs, does the LED still beat properly?
And if the interval is reasonably predictable you could send me logs a few days running so I can have a look.

I’ll pay attention to that, thank you.

I’m not sure about the interval. Thing is that I often use these devices on the weekends, and sometimes not at all during the week, and then I notice that they are hardly ever available and ready to go on Saturday mornings. But I don’t usually notice immediately when they hang.

Hi @spockfish - I forgot about it for a few days and was surprised just now that the device in question is still up and running. More than five days now, in my experience that makes it quite likely that it’ll hang soon. So I sent you another “feedback” just now, with this id: c42fd7f47f26c2b0

Rock solid.

One thing I can’t see in the logs… how’s the temperature looking?


Right now it says 54.8 (Celsius), which is pretty much what it always says. This device does not have any specific cooling, but it sits quite freely on a shelf and seems stable at its temperature. I haven’t had trouble running Pis like this for many years, so never assumed this could be the source of a problem - is your experience different?

Device is still running today - sent 1d0ea8ccef9644a8 just now, for the record :slight_smile:

Follow-up. Something might have happened now… I just refreshed the web frontend again on this device, and I found that it reacted very slowly. So I went to the Advanced page and hit the Feedback button - then a minute or so went by and nothing happened. Eventually, when I thought the device had died right then, it showed me this error:

You can see the feedback ID it was trying to send in the URL I wonder whether it arrived at your end?

Anyway, suddenly the device is responsive again. I sent yet another feedback right afterwards, here’s that ID: 4d9733b868795d27

I’m.seeing this as well. Both my rpi3 are disappearing from roon and the webpage after a couple of days and need to be rebooted to make them visible again.
One actually can’t be seen using the webpage for the moment. But strangly is visible and can be played to in roon.

*** update***
It disappeared from roon as well now so I rebooted the rpi
Feedback id : bf1cc20c3dfe2600

Some of you willing to try the beta channel?

1 Like

Sure would love to help out

Yes, I can do that. Edit: do you just want us to switch and update, or something else?

Follow-up. I’m surprised, and then again not - the device in question is still running, now up 9 days! That seems unusual to me based on prior experience, but of course it’s not unusual in the sense of watched pots never cooking and all that. For the record I just sent feedback 21f265b870311a2c, but nothing interesting seems to be happening.

Unfortunately I won’t be at home next week at all and I’ll shut down the device before I go. I’ll need to start a new test phase after I’m back. I have not changed to the beta channel yet, was waiting for feedback on that.

I run quite a few RPi 3’s some with HATs and others not just with Displays, and for the most part dont have any issues - mainly on beta but some stable too. most typically reboot daily I think…cant tell atm as im traveling out of country and everything at home is shut down

Interesting. Why, though? I never reboot anything if it doesn’t die on me first. Case in point, my work machine just now:

➜ uptime
 13:33:27 up 42 days,  4:32, 11 users,  load average: 2.40, 1.30, 1.40

Edit - I was going to add that Pi 3s have usually worked just fine for me as well - just a bit less so when running Ropieee. I believe this is true, but then I found that I don’t currently run any Pi 3s anymore. One other Pi I run turned out to be a model 2 - this one with pihole:

pi@raspberrypi:~ $ uptime
 13:42:38 up 68 days, 17:11,  1 user,  load average: 0.00, 0.00, 0.00
pi@raspberrypi:~ $ cat /proc/cpuinfo | grep Model
Model           : Raspberry Pi 2 Model B Rev 1.1

Feedback iD cb2239f21ce8ca63
I’ve got a strange issue that I have on 05/2022 and also had on 04/2022 - But not on 220211 which I keep reverting back to.
I don’t use ROON, I use HQPlayer Desktop and RopieeeXL (on an USBRIDGE SIGNATURE) as an NAA.
The music stops completely after 45 minutes. Always at the exact same point in an an album. I sent the logs from HQPlayer to Jussi and he points the finger at the NAA.
Hope you can help. Thank you.

Doesn’t an unlicensed HQPlayer only run for a short time then stop ?

Maybe a license issue