Pi with HiFiBerry XLR shows up on network but not Roon

Hi, pulled a Pi with Hifiberry XLR hat off the shelf that had not been used in a while. Web UI told me it updating, eventually got to web interface. Shows up on my network and of course the Web UI, but not showing Roon.

I sent feedback with f4724f3ecff77cda

IIRC at one point I was using it to feed a USB DAC rather than using the XLR hat. The goal today is to use the XLR hat. So I even tried turning off the USB output in web UI. It required a reboot, still shows up on network but not Roon.

Any ideas? Thanks!!!

No need to disable USB. Have you configured the HAT?

1 Like

Like this, right? Pretty sure that is the same as 6-months ago or so when I put it on a shelf.

Switched to different HiFiBerry HATs and back again. Enabled USB again…trying anything just to force it to save/reboot hoping for a change and still it shows on network with Web UI but Roon does not see it. Any ideas anyone?


Poking around a bit more…this is interesting. It shows up in Settings, About but not as a an audio device in Settings, Audio.

Problem solved. Hope this helps someone in the future. Double check the correct HAT. If you look at above screen shot I had “Digi” selected not “DAC”. I can only guess that long ago when I was using it as USB out only for a different DAC that the HAT also got changed.

For two days I’ve been looking at the selected HAT and just assuming it was the correct one due to the history of the device I was quickly seeing HiFiBerry and Pro but not paying attention to the Digi vs DAC part. Even when I switched and switched back to force a reboot I did not notice this. I just kept picking what originally was there…and it was wrong.

What an incredible waste of time on my part. Like the Led Zeppelin song - Nobody’s Fault but Mine.

I’m not 100% sure but I think the reason it showed up in Settings | About was the roon bridge portion or just the Pi part if you will. It was not till Roon could see the DAC that it showed up in Settings | Audio…obviously because up till that point there was no DAC.

1 Like