Pi with Ropiee Ethernet or WiFi


(Eric) #1

Hello, have bought the latest RPi for my son that he also can get Roon is his room.
Successfully installed Ropieee on it. Should I connect the Pi now via Ethernet or Wifi to the internet? Wifi at home is great, but I want to know which connection is the the one to go for to get the best sound from this entry-level Pi?


(Tony Reimann) #2

It shouldn’t make a difference sound wise but for stability sake I always chose Ethernet over WiFi given the choice.


(simon arnold) #3

Depends if your using USB for the output. If you are then you can run in to some issues on the latest Pi 3 b+ boards as the network port is not very good and interferes with the USB as they share the same bus. It works better with wireless on this model. I had no end of issues with mine. The 3b was ok though.


(Adam Goodfellow) #4

It seems to depend on the DAC too. I find its is always fine with my dragonfly red, but can be a bit sensitive with my pro-ject s2 - even at the same sample rate and MQA settings. The Dragonfly seem still reliable even with vanilla Raspbian desktop, docker running and even builds running on it (for DH releases). The S2 OTOH absolutely needs a low overhead linux (arch ass per Ropiee for eg) to not be glitchy.

Both are 32 bit ESS sabre DACs with XMOS controllers - I guess one has better implemented firmware than the other.


(Eric) #5

Yes - we want to use USB as output, so Wifi is the way to go…?


(Mr Fix It ) #6

Why don’t you just try one or the other and see what works best…the hardware and software can do both so its not going to cost you anything but some time. Personally I use LAN on my RPi3b’s the + I’m not using currently.


(Reader of the Internets) #7

If you’ve got good WiFi, yes, I think so. I had a lot of issues with my DAC until I switched the Pi’s networking to WiFi. The Ethernet and USB ports share a single controller chip, and if you’re sending packets in via Ethernet and then out again via USB, they seem to get a bit mixed up sometimes. Haven’t had any problems with using WiFi, though.


(Per Lundqvist) #8

Hm, I did run Ropiee on a RPi3 successfully as long as it was on the wired LAN. Today I wanted to move it to another place where Wifi is the only option. The RPi3 boots OK and I can open the admin page in a browser as usual, but now via wifi.

But, there is not a glimpse of it in the Roon list of endpoints…! (When I used it wired it turned up directly).

Do I need to perform some special magic to make it work via wifi?


(Tim) #9

@Per_Lundqvist

Did you check Roon’s Audio Settings to be sure it is enabled?

Both the Dr Red and BR Digi+ Pro are Pi 3 B+ endpoints running RoPieee and using WiFi.

Tim


(Mr Fix It ) #10

Is your WiFi on the same network segment…what is its IP address and what is the core’s IP address.


(Per Lundqvist) #11

Yes, it is on this list I miss the entry for the Raspberry.


(Per Lundqvist) #12

Good question, but yes, I have only one segment :-//


(Mr Fix It ) #13

In the wifi settings you need to get it on wifi ssid from the lan connected interface IIRC. also nothing will show up if there is no HAT setup and installed or no DAC turned on


(Per Lundqvist) #14

The ropiee is 192.168.1.152 (via wifi) and the ROCK is on 192.168.1.204 (wired).

Weird details I just discovered when I opened the desktop Roon app and found an update available (for the Mac) that it listed the Ropiee with correct IP and correct report that it runs latest version…

But still not in the list of available Roon endpoints.

I have not HAT on it since I just use one of the USB outputs. DAC downstream is always on…


(Mr Fix It ) #15

Did you select usb dac check box? If it works on lan then I guess you have. Maybe send Harry a feedback to troubleshoot with.


#16

is the DAC turned on? If your DAC is connected via USB, Ropieee will only show up as an endpoint if the DAC is turned on and Ropieee detects it.