Pi2aes with pi4 not working

In a bit of a pickle here.

Running ROON on ropieee/pi4 with pi2aes

  1. pi4 roon as a endpoint via usb to DAC = all good
  2. pi4 roon as endpoint via pi2aes HAT = no audio but roon is showing it’s working - (pic 1)
  3. ropieee configured OK in roon (pic 2)
  4. ropieee configured pi2aes = OK (pic3)

Thank you in advance for all your help. It’s a GREAT forum here :slight_smile:

  • shing

pic 1


Can you adjust the volume level in Ropieee?

has it worked before? or never?

couple of things I’d try…

restart the Pi

check the sample rate. (Pi2AES limited to 24/192)

make sure the DAC has the right input selected (duh)

make sure preamp/integrated has right input selected (duh)

The “duh” things sound silly, but I’ve had the same brain fart

1 Like

There’s also an issue with some pi2aes cards where it touches the USB ports of the raspberry Pi, that shorts some stuff and then it doesn’t work. Make sure it’s not touching, and if it’s touching put something non conductive in between, like a piece of plastic or electrical tape.

1 Like

When the audio is selected, the force vol and vol level is blanked out :frowning: so no trying

it was all fine until i powered down to tidy up things.

tried “all” none worked :frowning:

Force device volume at max on ropiee and try to use roon DSP volume control for attenuation …

thanks everyone for you kind assistance. I reinstall ropieee with the pi2aes hat. everything is working now. Don’t know what went wrong though :slight_smile: