Pi3 DietPi/Roon Bridge Wifi issue?

I am having an issue running my Roon Bridge/DietPi setup on Wifi.
On boot, it shows up in my router ‘connected devices’ list. I can SSH into it just fine and the Wifi setup seems OK.
It even shows up as an audio device in Roon.

The issue is when I press play. It takes a few seconds (it does not start and there is no sound), and then the Pi disappears from the audio devices in Roon. It disappears from the list on my router page as well.
It appears to drop the Wifi connection each time I try to play. What could be causing this?

If running with cabled ethernet, everything works just fine. But I do not have a permanent wired ethernet connection where the Pi3 is located, not at the moment anyway. So I wanted to use Wifi.
Is this not possible?

Best Regards,

What DAC are you using - perhaps its draining the power to the point the RPi stops working?

What power supply are you using?

I am using a Rega DAC connected with RCA cable (Hifiberry Digi+ pro), so it should not drain any power at all from the RPi.
The PSU is a standard wall-wart cellphone charger (HTC I think) and I believe it is rated at ~2A if I remember correctly.

RPi3 will need at least 2.5A if I recall correctly, and the HAT will mean a bit more needed. if you attach an HDMI display you will see on startup if it has enough power maybe - a big coloured square…if not a smaller one in the top right corner.

good is like this

Not enough looks like this


1 Like

Thanks for your response.
I will try to connect to a HDMI monitor to see what is going on. Seems strange that it would work fine through wired ethernet, but maybe current draw increases with Wifi use.

So I have tried with a monitor attached. No coloured square. Tried with a beefier PSU, no luck (2.1A, the previous one was rated at 1A). Tried the RPi3 official PSU rated at 2.5A and got it playing (with nothing attached, so I got no sound, but Roon showed that it was playing). Moved the RPi3 to my stereo again and hooked it up (same 2.5A PSU) and, a few seconds after I press play, the RPi3 disappears from my Roon devices. Not showing on the network at all and not getting back up without a reboot.

Just to mention: I have done a full format and reinstall of both DietPi and Roon Bridge. Wifi activated as well.

I do not understand this.

Have you tried running on cable? Wifi in RPI´s are not so good…

That’s an understatement. :slight_smile:

The radio in the Pi3 is quite weak – and things get worse when adding a HAT and/or case. I could not make mine work reliably in line of sight within 5 meters of the router.

If there is really no way to extend a wire to that location, you could consider a Wifi USB stick, Wireless Bridge (I’ve had good experiences with a bridging Airport Express) or Powerline adapter – but these do come with their own set of challenges.

As far as my experiences with streaming audio go – the only way to carefree happiness travels by wire.


Thanks for your responses.
I have tried wired ethernet and it worked flawlessly. Only issue is that it was temporary (trip wire through the living room :wink: ). I have tried a borrowed Powerline as well, and it worked too. Drawback for that one is added cost.

I have plans for wiring this up neatly, but was hoping to be able to use Wifi in the meantime. I really wanted to make it work. Seems to be a no-go.

I just figured that it was strange that I could log into it and download updates etc., but when I tried to run Roon through it; Gone!

Wifi works well over 95% of the time for me. No hat.

For wifi I am using mostly one of these USB wifi sticks. Did not had dropouts or connection drops so far:

CSL 300Mbit USB WLAN Adapter


@crieke How easy are these to configure on DietPi?

It was not very hard to configure. You could disable the onboard wifi in the dietpi config somewhere. I can look it up and post more details tomorrow.

@crieke Thanks.

To use a USB Wifi Adapter in dietpi, launch dietpi-config and select:

:arrow_right: 7 - Network Options: Adapters

:arrow_right: Onboard WiFi: Enabled | Select to toggle

You can toggle the onboard WiFi with the last selection. It should read Onboard WiFi: Disabled | Select to toggle if you want to deactivate onboard WiFi and use an USB WiFi Dongle. For the linked dongle, no additional drivers or modifications were required.


Thanks. This works a lot better than the onboard. Surprised it is so easy to set up. @crieke

Wondering what the USB bus situation is on the RPi3. Is there an issue using a USB wifi dongle and outputting to a USB DAC?

I think the USB bus is also shared with the ethernet port. As most users have no issues using Ethernet and a USB DAC, I guess it would not make any big difference when using a WiFi Dongle + USB DAC.

Same problem here – works fine with USB DAC over Wifi, but keeps dropping out with the Digi+ Pro. Ethernet solves the problem, but I think the issue might be Digi+ Pro’s Coax out – maybe it has to do with grounding or isolation.

1 Like