Pi3, Pi official screen - all working but no display tab

I’ve got 3 Pis with the official 7" screen and RPi v2 all working beautifully. Until one of the Pi connectors died!

Now got a Pi3 - the Pi connects and works with ROON, and the output to the screen works until “We’re ready. Ropieee is RUNNING”. Logging in to ropieee reveals that the ‘display’ tab is missing.

Tried the usual things - new cable, new ropiee download, took it all apart and set up again, all with no luck. Am I doing something daft?


I built a 3B+ with official screen 2 days ago. It did discover the screen but didn’t offer me any information or art until it had rebooted over night. That was despite a couple of manual reboots.

Are you one release 100? That’s the current latest version

Odd - I’ll give it 24 hours to see!

Yep - release 100

This is my ropieee screen - note, no display option…

This is likely because the display was not detected during the install process (and so the software wasn’t configured). The best thing to do is to do a fresh install from scratch. I’d do this before sending logs.

1 Like

Hi @Rick_Carter,

Nathan is right: the screen is not detected during install, hence there is no ‘display’ tab in the web interface.
Please keep me posted after you’d retried.



Can you send me feedback (it’s on the ‘advanced’ tab)? I really want to know what happened…

Oddly enough I can’t get the screen to display information again! It just says unknown.
Unique identifier aac389c08b7a9cc4

you have configured the zone you want to display?

It gets stranger - I get text on the screen as above with the install which I ran from new this afternoon. With a new download and install I get just a blank screen! I’ve tried different power supplies (I use a separate supply for the screen in all my setups) and now 3 different SD cards.

I’ll have another attempt over the weekend and update progress here.
Thanks for all the help so far.



I see 3 zones, but none of the is called ‘Pi’, which is what you configured in RoPieee.
So that’s not gonna work. You need to give it the exact name of the Zone you want to display/control.

1 Like

OK, sorted. It is just rebooting now.

Sorted! Turned out to be an intermittent connection with the short usb extension cable (with a right-angle connector) I use for the power to the screen. Sometimes it worked, and sometimes it didn’t!

Thanks for all the advice…

1 Like

Is the official pi LCD display still being supported by the latest release of ropieee? I just installed the latest and no ‘player’ ever comes up on the screen, even after configuring the screen. Seems I read something awhile back that it wasn’t being supported anymore? I’ve got the IQaudIO DAC hat working fine, just no display.


official 7” display is the supported one

Is the Raspberry Pi 4 support different? I’ve been running the Official screen on an RPi3 for about a month. I just moved it to an existing RPi4 running Ropieee and while the screen is working fine and I watch Ropieee boot, I never get the display tab on the settings pages and I never see the Roon extension start (in Roon or on the screen).

So, existing Ropieee on a RPi4, but only just added the official screen. Do I need to reinstall or reconfigure somehow?

Are you running the latest version?

Yes, RoPieeeXL 2022.06.2 (0400)