Pi4 not showing in audio settings in Roon

Hi. I just got my RPI4 in the post today and installing ropieee went well and I can see through the web interface that all looks good. Audio USB enabled and connected via wifi to my router. I have tried my Dragonfly Red and Chord Mojo in the pi but nothing is showing up in the audio section of Roon. I have rebooted the pi and my Roon core. Oddly if I go to the About section of Roon settings ropieee shows up there and says I have the latest RoonBridge installed. Can anyone help. I’m brand new to Raspberry Pi so maybe I got something very wrong somewhere.

If you go to Settings > Audio is the RPi listed there? Is it Enabled?

Hi Martin_Webster. Thanks for replying. No nothing is showing in Settings - Audio. So in Settings >About I can see ropieee RoonBridge and looks fine but in Settings>Audio it is not showing with either of my USB DACs connected to the Pi.

What’s the IP of your Core and the RPi (see Settings > About.) Also, double check that Audio USB is enabled on the Pi. This setting requires a reboot to take effect.

IP of Core is 192.168.1.68 and the Pi 192.168.1.91 Yes Audio USB is toggled on.

Have you tried unplugging the DAC and putting it on another port? My cobalt sometimes does not show up and this fixed it.

Thanks CrystalGypsy but yes I have tried both DACS in all 4 ports but no good.

Go to the Advanced tab in Ropieee and click Send Feedback, grab the code and post here. Hopefully @spockfish can assist.

Sent feedback and the code is c1590d0406908b1c. My Dragonfly DAC is connected just now when feedback sent.

I’m not sure what is going on, but in essence it’s very simple: there is nothing connected to USB, hence there is no audio device, hence it does not show up in Roon.

That is strange but that is what I saw when I ssh in and used aplay -l …Nothing. Although my Dragonfly lights up and is powered. I upgraded to ropieee XL to see if that helped but it now means that ropieee shows up in audio settings as an airplay endpoint only. Still no DACs visible. Tomorrow I am going to download ropieee again and use a different microsd card and start again. Not sure it will help at all but I might as well try as no good as it is sadly.

1 Like

@Sam_King installing RoPieeeXL is a smart move for debugging because if you can’t get audio playing via an XL option such as AirPlay, you can rule out a Roon issue and focus on the Pi.

Thanks all for your suggestions but still no joy. I redownloaded ropieee and re-flashed my sd card. I let the Pi finish its set up routine, changed the time zone via the web interface and rebooted. I then inserted my Dragonfly DAC and was pleased to see it appear in Settings > Audio in Roon. Just to check it wasn’t a fluke I pulled out the Dragonfly, waited a few minutes then reinserted it - now it is gone from Roon and will not come back. tried the Chord Mojo and it doesn’t appear either. So briefly it worked after reinstall then never again.

Maybe you need an eeprom update; there is a known issue with early firmware on the Raspberry Pi 4 that affects USB.

Thanks @Martin_Webster for that tip. I checked using rpi-eeprom-update and the boot loader in indeed out of date - installed is May 2019 and latest is September 2019. But it won’t update. Do you know the commands to make it update? According to the RPI4 instructions that command should do it but it is not updated.

I think it’s rpi-eeprom-update -a.

I have this exact issue today.

Just set up a Pi 4, and it’s all the same as you have - shows up as Airplay endpoint, but no Roon endpoint showing (I’m using a Cyrus Soundkey).

I’ll let you know if I figure it out, and any help is appreciated.

There is no reason to update hte firmware via the command line, you can do that from within RoPieee:

Go to the ‘info’ page and there you see the USB firmware version mentioned. From there you can upgrade it by clicking the update button.

1 Like

I tried that with no luck unfortunately.

Do people suspect the issue is with getting USB dacs working on the PI 4 generally, or is it likely a RoPieee issue?

Edit: I see from another thread many people have USB dacs working with no problem on the Pi 4 with RoPieee, so not sure what’s going on here.

As an experiment I had a spare sd card. I downloaded Raspbian mini/lite and installed roonbridge on it. This time the Dragonfly showed up the usual once in Roon Settings > Audio but I got my Chord Mojo to show up twice! Now both gone again and won’t come back. There is a difference though. With Raspbian I can see the RPi listed in Settings > Audio 3 times - presumably it has its own DAC. But it doesn’t show at all with ropieee.

I updated the USB firmware via the ropieee web interface but didn’t help and my boot loader still seems to be an old version (albeit only a few months).

Edit. I should add that Roon will play to the Pi on Raspbian by enabling its own DAC in Roon and listening via the headphone socket.

1 Like