Pixel2 will not find roon core

Core Machine (Operating system/System info/Roon build number)
Windows 8.1 machine.
Roon 1.7, build 710 64bit

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)
TPlink Archer AX-50, wifi6 router. Operating through wired connections, except with Pixel 2 and Huawei tablet

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)
No issue with audio devices yet.

Description Of Issue
Pixel 2 running android 11 cannot find Roon Core, continues to search. Huawei android tablet (android 8) found it no problem and works fine. Both are on the same network. I tried specifying in the search box, no luck. I have the remote discoverable button checked…


Possibly no help to you as you do mention the network already but I have a Pixel 2 as well. Every time I have this problem it is because I am on a different WiFi hotspot to the core (should wire it I know), even though it’s the same network. One is 2.4, the other 5 gig.

I have 2.4 and 5g frequencies on my home network, but I mostly stick to one of them.

My kids Chromebooks don’t like the 5, so I have specific hotspots for that. If my phone connects to one then I lose Roon.

Hello @Jim_Fuerstenberg ,

Welcome to the forum! Can you please check to see if your router has an IGMP Snooping or IGMP Proxying setting? This setting has helped with some discovery issues in the past.

I looked, but have no idea where to find that. i went through the settings

i found IGMP and enabled IGMP snooping and IGMP proxy…my pixel2 still cannot find the roon core.

Hi @Jim_Fuerstenberg

Can you confirm the IP address of the remote and the IP address of the Core? Are they on the same IP range?

my pixel 2 is at

in the Roon app, i cant find the IP…but it says the subnet for linn streaming is

Hi @Jim_Fuerstenberg ,

Are these networks on the same subnet? It sounds like they could be on different subnets and not actually connected. Can you check to see if you get the same IP range on both 2.4gHz and 5gHz frequency?

both the phone and tablet are on the 2.4ghz network. the subnet is per my phone. My router also shows the subnet mask to be that…I cannot find that setting on my huawei mp5 tablet…which works fine with the roon core installed on my pc (the pc is connected by ethernet to my router). the phone and tablet are of course wireless.

Hi @Jim_Fuerstenberg ,

The subnet mask can be the same, but the IP addresses can still be different, I would ensure that the same IP scheme applies for all the digits except the last 3 e.g. 192.168.1.XXX & 192.168.1.YYY for both Core and Remote.

from what I posted earlier. the phone which will not connect shows IP 192.168.0.xxx; the roon core shows 192.168.0.xxx (at least under "subnet for Linn streaming)

I am still waiting for assistance on this problem. Please see prior response.

Hello @Jim_Fuerstenberg ,

Thanks for confirming that the Pixel and the Core on the same network.

Have you also tried to specify the manual IP of the Core?

Is there any change in behavior if you try to uninstall + reinstall the Roon app on the Pixel2 device?

How do I specify the manual IP of the core? And what should I specify as the IP?

I just tried uninstalling and reinstalling the app on the Pixel 2. Same response, it continually looks for but does not find the Roon Core.

thank you.

another update…after the last update, the app now connects intermittently to the Core…

1 Like

Hello @Jim_Fuerstenberg,

Happy to hear that there’s been an improvement here, hoping that this remains resolved!
In case the issue re-occurs:

There is a “Help” button that appears on the “Choose your Core” screen after waiting 60s.

This would be the IP address of the Windows Core, you can find this listed in Roon Settings → General under the Core name.

I was only able to access Roon twice on the phone. The good news is that the Pixel2 is listed under setting/audio. but when I open the app on the Pixel2, I get “waiting for remote core” …roon is till trying to connect, but it does not connect…

I do not see that IP address…under General , the top listing is Roon Core, This PC, which gives me the option to see account info. On the Pixel, no help button appears to Choose Your Core. The only option is Select a Different Core.