PLAY causes "unexpected error - limiting Roon Radio to local library"

Core Machine (Operating system/System info/Roon build number)

ROCK v1.8 build 756 on Inside Tech i7 gen 8 NUC

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Everything on Ethernet except iPAD remote, via Amplifi router / Netgear Prosafe 24 port unmanaged Gigabit Switch JGS 524.
Remote on iMAC macOS 10.12.6 (and iPAD)
Library storage on Synology DS211j NAS hardwired to Switch.

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Lindemann Source (LAN)
Lindemann Limetree Network (LAN)
Sonos AMP (LAN)

Description Of Issue

I play mainly classical music. More often than not, using PLAY after selecting either ARTIST or COMPOSER causes the flag “unexpected error - limiting Roon Radio to local library”. Roon then plays either a sequence from the local library, or sometimes a single track / composition with no further selections. It doesn’t always happen, but is reproducible. In other words, there are a few composers or artists, where PLAY correctly triggers a sequence from the library (local and Qobuz) + “new” Qobuz tracks / compositions not in the library . Delibes, Monteverdi or John Cage are Composers where PLAY works. Miles Davis, Chick Corea are Artists where it works. I cannot find a single Classical artist where PLAY works (e.g. Angela Hewitt, Alfred Brendel, Colin Davis, John Eliot Gardiner). PLAY does not work properly with most Classical composers e.g Bach, Handel, etc.

I wondered whether it made a difference whether I had something from the composer already in the library (local / Qobuz), but no.

I also wondered whether the amount of composition / tracks / data associated with a composer might be the issue. I therefore tried with some more “minor” composers with few albums / compositions e.g. C F Abel, Arensky, Hans Abrahamsen, but no difference.

I have tried several reboots.

This really makes the use of PLAY in any page other than the album page pretty pointless.

The fact that it does vary according to the composer or artist strongly suggests to me that this is not something local, but intrinsic to Roon.

It would be really nice to see this working consistently (or at any rate 75% of the time, not 5%).

Could Roon support please comment? I know this has been reported before, and supposedly sorted.

Other threads are now reporting same problem.

Apologies for the trouble here, @Matthew_Lyttelton

Apologies for the delay! Our team’s queue is longer than typical at the moment, but we’re working to get back to everyone as quickly as we can.

This should be resolved now but if you’re seeing any issues still please let me know!

This is still not working. The best I have seen over the last 9 days is working for about two thirds composers. Today it throws “unexpected error” for all composers and artists.

Please could Support respond?
In effect the Play button on the Artist or Composer page doesn’t work.

Is this something to do with my particular setup, or are other users experiencing it?

Is this for all streaming sources or just Qobuz?

If support will confirm that it is a recognised bug that they are still working on, then I will know not to try using it.


Hi @Matthew_Lyttelton

Apologies for the delay here — Yes, there appears to still be an issue occurring with some composers. Our team is working on resolving this ASAP and I’ve just requested an update from them. I’ll follow up as soon as I can!

Thanks. Currently on a random sample, the error occurs on about 60% of composers.
Also quite a few Artists ?30%.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.