“Play from here” poor user experience [Ticket In]

Roon Core Machine

Win 10, Essentio Desktop - 16GB Memory - 2TB Hard Drive

Networking Gear & Setup Details

One wifi router from Xfinity. Does not indicate model number on the device.

Connected Audio Devices

Lumin X1, XLR Analog connection to preamp (Linn Klimax Kontrol)

Number of Tracks in Library

Using Tidal

Description of Issue

When selecting “Play from here” in the queue the list jumps past the song selected to play. Just started happening recently. Very poor user experience as you have to scroll to the song playing or select “Jump to now playing”.

Please fill out the rest of the template to give more details on your setup. The more info the support team have, the better they can diagnose the cause of the issue. Thanks.

I’ve noticed the same behavior. Annoying….

I’m not sure when it started, though.

As @Geoff_Coupe said…some further equipment details are needed on this one.
I just tested it on three different remotes, PC, Android and iPad with the expected correct results so it’s something funky and peculiar.

1 Like

It happens intermittently but pretty frequently during every listening session. It is happening both on my Ipad mini 4 and iphone 8 running the Roon app. I am running the core headless on the PC that I mentioned in my original post. What other details are needed? Thank you!

David, can you provide any more details on your network? This type of issue may be a network congestion issue. What is connected via Ethernet cable to what, what is connected via WiFi (other than the iPhone and iPad), and are you able to select the WiFi band (either 2.4 GHz or 5 GHz) on the Xfinity router?

I just tried it again; happens 100% of the time if I select a track far enough further down the list for the “Jump To Now Playing” to appear at the top before selecting the new track.

PS - I’m just posting this info to try to help the OP. If this just confuses things for the OP, I’ll create a separate thread.

Thank you! Not confusing at all and no need for a separate thread. I tried the use case you just described and you are absolutely correct, it happens 100% of the time when you scroll down further into list. I also noticed same behavior happening if I close the app or turn off my phone and then when I go back to the Roon app the queue does not always show the current playing song at top of list and I have to go through same use case to jump to the current playing song. This behavior may be related as I do not recall this happening in the past. I appreciate the assist!

1 Like

Odd issue. Tried it here on both Qobuz and Tidal in the UK. no such issues so it’s not affecting everyone. Are you both in the same country/area?

Interesting, thanks for information. I am located in the US (Aurora, IL).

I really do not believe it is network related as I have not changed anything or added more devices and this has only started happening during the last month or two. I have way too many devices connected to my wi-fi to list. The router automatically selects wi-fi band based on device. In terms of ethernet connections, I have my PC, NAS (Netgear ReadyNas) and my Lumin X1 connected to ethernet ports of my xfinity wi-fi router. Thanks

US here as well.

BTW, happens on both local and streamed (Qobuz) content.

I’m not sure “network congestion” is a factor. Wouldn’t that result in sluggish/laggy response time? Roon is very snappy. Response to selecting a track further in the queue is instant.

Hey @David_Markley,

Thanks for taking the time to write in! It’s great to see you on community again.

I wasn’t able to reproduce this on my end after trying a few different streaming methods and different-sized queues (I’m running a headless core as well.) For next steps, please reproduce the issue again, and share a few timestamps of when the issue occurs. That way, we can enable diagnostics on your account and take a look at what might be going on at the time of the issue.

Also, if possible, can you test this issue while on a different network?

Thanks, David, I’ll be on standby for your reply :+1:

1 Like

Hi Ben, thanks for helping on this issue. I just recreated the problem three times in a row on Aug 25 at 7:11am CST. My queue had about 380 songs in it all from Tidal. I loaded these from a Roon playlist that I created a week ago. As far as testing on a different network, I only have one network, so that is not possible right now. If I can provide any more details to help isolate this problem, please let me know. Thanks!

1 Like

Hey @David_Markley,

Thanks for sending those over! After reviewing your account, we’re seeing some hiccups with your RAAT server. Let’s have you refresh your RAAT server database to see if that helps with your issue.

You can generate a new RAATServer instance on your device by following these instructions, but please be aware that this will reset your Roon Settings → Audio Tab to factory settings and I would advise making a backup of any custom DSP settings you have:

  • Create a Backup of your current Roon database
  • Exit out of Roon
  • Navigate to your Roon’s Database Location
  • Find the folder that says “RAATServer”
  • Rename the “RAATServer” folder to “RAATServer_old”
  • Restart the Roon App to generate a new RAATServer folder

Let me know if your issue persists after the above :+1:

Hi Ben. I followed your instructions and it is still happening. I last saw behavior at 4:20pm CST. Thanks

Hey @David_Markley,

Thanks for the information. Our team was able to reproduce this issue, in order to better clarify the issue, if you could provide a gif or screen recording of the issue happening on your end, that would be immesnly helpful :+1:

Hi Ben. I made a screen recording, but I am unable to upload a MP4 file (site says file extension is unauthorized). If there is an alternative way to get to you, please let me know. Thank you!

I never bothered to report this because it’s been happening to me for as long as I can remember, on both Android and Windows. But seeing as it’s a ticket now, I’ve uploaded a screen recording. This was recorded on my Android tablet but it also happens on my (Android) phone and in Windows. I’m using a ROCK instance sitting on a NUC, if it matters.

Screen recording here (sync.com)

To avoid confusion, what is happening is this:

  1. I click play on the track named ‘Saku’ (just so something is playing)
  2. I scroll down a few screens
  3. I click on the track named "A Midsummer Evening’ and select ‘play from here’
  4. The list scrolls to some random point and I need to click ‘Jump to now playing’ to properly reposition it.

Note: in this example the tracks happen to be queued from Tidal but this also happens with locally stored files.

Hope that helps.

Edit: going over some of the earlier responses: it has nothing to do with the network; I have a rock solid gigabit network; this happens even when Roon is pretty much the only thing using up appreciable bandwidth. It also happens on all my remotes, whether they’re on wifi (tablet, phone) or a cabled connection (Windows). I appreciate a lot of reported issues are undoubtedly related to circumstances beyond Roon’s control (like shoddy network setups and garbage wireless connectivity) but in this case you’ll just have to take my word for it: I know my way around a computer, and I know my network is not at fault.


Thank you for providing a video. This is exactly the behavior I am seeing and that prompted me to post the issue. I am certain this is a software bug and to your point nothing to do with network latency. This issue is somewhat recent (perhaps in last 6 months or so) as I would have noticed this a long time ago if it were happening as it is very annoying. I suspect it was inadvertently introduced during new software enhancements/versions. Thanks!