Play Now not playing despite pop-up confirmation & Roon Radio: Nothing Similar to Play happening frequently

Roon Core Machine

NUC5i3RYH 8GB ROCK latest release

Networking Gear & Setup Details

Netgear Nighthawk RAXE300

Connected Audio Devices

KEF LSX Ethernet

Number of Tracks in Library


Description of Issue

Occasionally when I press Play Now under main artist name, whatever is currently playing stops, but nothing plays despite a pop-up telling me the Artist is playing, Navigating to a different artist and Play Now works again, navigating back to original non-responsive artist leads to a repeat of the fault. Playing From Here under Popular works and loads a queue of the artist’s tracks

Also, with frustrating regularity now, Roon Radio is reporting Nothing Similar to Play despite me having a huge and varied library

Hi @MrDenis ,

Thanks for reaching out. I tried to start radio for this artist on my end and I was not able to reproduce the issue you describe.

Can I please ask that you reproduce this issue, and then immediately after you notice it, access your Roon logs using these instructions, upload a set here, and let us know once you’ve done so?


Hi Noris, thanks for the reply. I’ve uploaded the zipped log files as per instructions. Let me know if you need anything else.


Hi - I don’t know if you had a chance to see what might have been wrong - anyway - playing that particular artist radio is now working

I haven’t yet listened enough to see if the secondary issue, of Roon Radio not being able to match a track, had been resolved so please keep that part of the ticket open


1 Like

Sadly this error has now reappeared with different artists

Can I reopen the ticket please

Hi @MrDenis ,

The ticket is still open. What artists are you seeing this with? Can you note the exact local time + date when you get the error and let us know that info here?

Hi Norris - how did you get on with the logs I sent when I first opened the ticket?

I’m having this exact same issue.

@noris I’ve once again uploaded logs after Roon said it was playing an artist, stopped current queue, but didn’t play - this time can somebody look and see what’s going on?


The second issue is also still unresolved - today I discovered that playing the pictured track from Tidal resulted in Nothing Similar to Play message when Library limited to local - however if I added the track to my library the Roon Radio acted as expected - the uploaded logs will have that info too

1 Like

Hi @MrDenis ,

It sounds like you’re also having issues with ARC, so let’s troubleshoot this first and revert to this thread after, as the two may possibly issues may have a common cause:

1 Like

@noris - I’m not getting much back on the other thread - I’ve had the same issues occurring again

Issue 1:
Search Jah Shaka - select artist Jah Shaka - press Play Now - current audio stops - Roon displays Playing Jah Shaka - no audio plays

Issue 2: Listen to Tidal track - Roon Radio automatically play music based on your cue (YES) - Limit Roon Radio to library (YES) - Roon does not queue any further tracks and displays Go find something to play

I’ve uploaded logs

Just to add - on a couple of occasions - despite not being queued - the following track within the album will play though according to Roon there is ‘nothing playing’ - this just led to an explicit track being played - play stops at the end of the unqueud track

Hi @MrDenis ,

Some time has passed since your report, so I wanted to check in with you here, are you still having this same issue? I looked over your previous log sets and I noticed an error that we resolved in a recent Roon release. Please do let us know if you are still having issues and we can take another look, thanks!

I’ve just tried searching Jah Shaka - then on his artist page hitting Play Now - current queue stops - Roon indicates Jah Shaka is playing - nothing plays - same result after Roon restart

Still getting instances where Nothing Similar found pops up - seems to be when listening to Tidal and Roon Radio limited to library

I’ve been seeing this failure from “play now” on the artist page, too, and for me it seems to happen if I both have no tracks by the artist in my library AND have Roon Radio set to “limit Roon Radio to library”. Once I unselect the “limit Roon Radio to library,” then the “play now” button on the artist page works again.

Check your Roon Radio setting and see if that doesn’t fix it?

1 Like

Good shout - though it’s a workaround rather than solution for me. I want to be able to listen to something not in my library but for Roon Radio to pick up the thread from that and take it into my library.

I also didn’t realise that Play Now on an artist page is just a more selective version of Roon Radio.

Thank you.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.