Play Only This Album

in the blue menu, have the option to play only selected album and then stop playing and don’t shuffle

You have to go to Settings/Play Action and under Album enable Shuffle. It is not on by default.

And make sure Roon Radio is disabled in your queue!

2 Likes